summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-20 15:22:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-20 15:22:00 -0500
commit809a08d8a13d963bdfa9da3630f2b114c8cc5953 (patch)
tree5cd719b435ffe42f02f880cd53127f53d90e3c19 /sys-cluster
parentgnome-extra/gnome-integration-spotify: fix dbus integration (diff)
downloadgentoo-809a08d8a13d963bdfa9da3630f2b114c8cc5953.tar.gz
gentoo-809a08d8a13d963bdfa9da3630f2b114c8cc5953.tar.bz2
gentoo-809a08d8a13d963bdfa9da3630f2b114c8cc5953.zip
sys-cluster/neutron: use chown/chmod instead of fperm/fowners
Closes: https://bugs.gentoo.org/784146 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/neutron-2020.1.9999.ebuild6
-rw-r--r--sys-cluster/neutron/neutron-2020.2.9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-cluster/neutron/neutron-2020.1.9999.ebuild b/sys-cluster/neutron/neutron-2020.1.9999.ebuild
index a48cc0a000dc..b7172660e8fd 100644
--- a/sys-cluster/neutron/neutron-2020.1.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2020.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -205,8 +205,8 @@ python_install_all() {
unpack "neutron-ml2-plugins-${PV}.tar.gz"
# correcting perms
- fowners neutron:neutron -R "/etc/neutron"
- fperms o-rwx -R "/etc/neutron/"
+ chown neutron:neutron -R "/etc/neutron"
+ chmod o-rwx -R "/etc/neutron/"
#remove superfluous stuff
rm -R "${D}/usr/etc/"
diff --git a/sys-cluster/neutron/neutron-2020.2.9999.ebuild b/sys-cluster/neutron/neutron-2020.2.9999.ebuild
index 11c02b079653..a73317fb3f88 100644
--- a/sys-cluster/neutron/neutron-2020.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2020.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -202,8 +202,8 @@ python_install_all() {
unpack "neutron-ml2-plugins-${PV}.tar.gz"
# correcting perms
- fowners neutron:neutron -R "/etc/neutron"
- fperms o-rwx -R "/etc/neutron/"
+ chown neutron:neutron -R "/etc/neutron"
+ chmod o-rwx -R "/etc/neutron/"
#remove superfluous stuff
rm -R "${D}/usr/etc/"