summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-25 14:25:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-25 14:26:05 +0100
commit984baabb883d2b8c3be138ca5386737ea42dd77d (patch)
tree7d50a713eb9ae6d4db7269dfbc1c7b440ca7017f /sys-devel/bison
parentdev-python/jupyter_console: Version bump. (diff)
downloadgentoo-984baabb883d2b8c3be138ca5386737ea42dd77d.tar.gz
gentoo-984baabb883d2b8c3be138ca5386737ea42dd77d.tar.bz2
gentoo-984baabb883d2b8c3be138ca5386737ea42dd77d.zip
sys-devel/bison: Bump to version 3.2.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/Manifest1
-rw-r--r--sys-devel/bison/bison-3.2.4.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 494aad81efe3..c2665fea13cd 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -6,3 +6,4 @@ DIST bison-3.2.2-patches-01.tar.xz 9300 BLAKE2B ce48cd493d6fd5767b76125599c8c603
DIST bison-3.2.2.tar.xz 2091244 BLAKE2B 09448b6af67e05a2cc5011eb9de987473cdaa1a9d387baf0df876811ba052682fcf24df06c0d26fe019ce75a194e1f046f0e6f0ab6b895cf28b3d4f75f0c9091 SHA512 b1a49f5c987f1b39febb6b9557d5bafd0ab4952f4e9b9c3ad7650210643ba3bbf365367bf1736f396c1b881b13fff52a69409198fad5a4120c19f29c0fb4e2f1
DIST bison-3.2.3-patches-01.tar.xz 9460 BLAKE2B 3e9f3e636d774d005c861c4f5fe121a862cbfc38f5efd5bb7ac7d2944f71e80eabd6621f3f5507d9f78727f22b574581c9b694457c63b5181a8cc1a0ac69d294 SHA512 6c599583b67f8999c8e2c8492a19ad0b43bbadef1d9c062c752e7c1cc3d178c2106262c70c998a0588bc6255ec27b2623a90267e0858e2d776ac2f4cf6cb688f
DIST bison-3.2.3.tar.xz 2092048 BLAKE2B b5f98850e1b69fcc0f5e559c12708cde59f00f2e633b7a2a0c9ddc849f548265bb30873e4e64e1b2a72e51cb5f1caef7ec0ab09aa2c8d7dae04ae71854da7096 SHA512 6f86ebc0d66e8dcd3709b25938b2bf43b94e7f4a0a20e586ba42c55c8747543fb48ca47cc2116e4bad8d2152de58c8c75b284a9b254ab8c8ecef292967657494
+DIST bison-3.2.4.tar.xz 2094568 BLAKE2B 9b7617b25f1b151c3b86a5f57e733543160fb40f992ff968eaadfc91d8f1a67f56d0afeafbed5003ea1a5e0c861b12ef4cc27065d1b6cbc1d0845710164d84e2 SHA512 652b54fdee969bbc17eeb04d05d65f143e8e0e1b46ac2574e3a76687b9bd916c9a0c97658b4f8357958d64e87fe2a6a2a98a6c312970f0e74fb4445962e9daae
diff --git a/sys-devel/bison/bison-3.2.4.ebuild b/sys-devel/bison/bison-3.2.4.ebuild
new file mode 100644
index 000000000000..4d3d12b7fd05
--- /dev/null
+++ b/sys-devel/bison/bison-3.2.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.2.3-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.1-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.2.3-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED%/}"/usr/bin/yacc{,.bison} || die
+ mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED%/}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT%/}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}