summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-28 17:39:13 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-28 18:00:32 +0200
commit563c9484bc211f8862cc80313fde89f3868a75c1 (patch)
treedccd557ee573691d76a525fcf0c646b0a7e636c9 /sys-devel/clang-common
parentsys-devel/lld: Bump to 7.0.0rc2 (diff)
downloadgentoo-563c9484bc211f8862cc80313fde89f3868a75c1.tar.gz
gentoo-563c9484bc211f8862cc80313fde89f3868a75c1.tar.bz2
gentoo-563c9484bc211f8862cc80313fde89f3868a75c1.zip
sys-devel/clang-common: Bump to 7.0.0rc2
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/Manifest1
-rw-r--r--sys-devel/clang-common/clang-common-7.0.0_rc2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
index b783370b44dc..b7065cf84ab7 100644
--- a/sys-devel/clang-common/Manifest
+++ b/sys-devel/clang-common/Manifest
@@ -1 +1,2 @@
DIST cfe-6.0.1.src.tar.xz 11905772 BLAKE2B abb60e9f9827d1d8a24f0aaf8a1d1e32979293cc401258d230f93290e633645747fd0344af189ac7081b06be2cada503364e1e432b37110ade4b3578e40c7605 SHA512 f64ba9290059f6e36fee41c8f32bf483609d31c291fcd2f77d41fecfdf3c8233a5e23b93a1c73fed03683823bd6e72757ed993dd32527de3d5f2b7a64bb031b9
+DIST cfe-7.0.0rc2.src.tar.xz 12539260 BLAKE2B 7e7f006154aff2e4cfde377820c3482769ddb22a14ef45c98cb1645262ba36a5cb2159097bd159141e37cc4a06dddd93e38fdac4d763450834719daf088a2d15 SHA512 ae4c4f2b5f3c97147bcbb5d74e07588ff2ede7c131cb4e782ff077b68da1f02042a87f44227574a2883da7ce6827cd188898c862b0e09a4a70316df16193811b
diff --git a/sys-devel/clang-common/clang-common-7.0.0_rc2.ebuild b/sys-devel/clang-common/clang-common-7.0.0_rc2.ebuild
new file mode 100644
index 000000000000..144dd9bebea4
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-7.0.0_rc2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}