summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-25 03:08:39 +0100
committerSam James <sam@gentoo.org>2022-08-25 03:09:27 +0100
commitd362b1c7e6ed7a7b238d62fe69c90230350b269c (patch)
tree5dec90e77652f6b6d7e613fb9b2352c4ec88890b /sys-devel/cproc/cproc-9999.ebuild
parentsys-devel/qbe: style tweaks, EAPI 8, respect CC (diff)
downloadgentoo-d362b1c7e6ed7a7b238d62fe69c90230350b269c.tar.gz
gentoo-d362b1c7e6ed7a7b238d62fe69c90230350b269c.tar.bz2
gentoo-d362b1c7e6ed7a7b238d62fe69c90230350b269c.zip
sys-devel/cproc: style tweaks, EAPI 8, respect CC
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/cproc/cproc-9999.ebuild')
-rw-r--r--sys-devel/cproc/cproc-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/cproc/cproc-9999.ebuild b/sys-devel/cproc/cproc-9999.ebuild
index 74f03bd8630d..163ffe80afba 100644
--- a/sys-devel/cproc/cproc-9999.ebuild
+++ b/sys-devel/cproc/cproc-9999.ebuild
@@ -1,11 +1,13 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ "${PV}" = 9999 ]]; then
- inherit git-r3
+inherit edo toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://git.sr.ht/~mcf/cproc"
+ inherit git-r3
else
CPROC_COMMIT="6fabc79d81de56b6c1cdcc2242933fd792e2ddf9"
CPROC_P="${PN}-${CPROC_COMMIT}"
@@ -17,10 +19,11 @@ fi
DESCRIPTION="C11 compiler using QBE as backend"
HOMEPAGE="https://sr.ht/~mcf/cproc/"
+
LICENSE="ISC"
SLOT="0"
-DEPEND="sys-devel/qbe:="
+DEPEND="sys-devel/qbe"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -30,5 +33,7 @@ src_prepare() {
}
src_configure() {
- ./configure --prefix=/usr || die
+ tc-export CC
+
+ edo ./configure --prefix=/usr
}