summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2017-10-11 14:39:20 -0700
committerStephen L Arnold <nerdboy@gentoo.org>2017-10-11 14:40:10 -0700
commit559cf5f4b15f024e21eab5f2458effe7806da8ad (patch)
tree6120b599070139eab65c82c949565950d01022dc /sys-devel/gdb
parentdev-python/docutils-glep: Bump to 1.0 (diff)
downloadgentoo-559cf5f4b15f024e21eab5f2458effe7806da8ad.tar.gz
gentoo-559cf5f4b15f024e21eab5f2458effe7806da8ad.tar.bz2
gentoo-559cf5f4b15f024e21eab5f2458effe7806da8ad.zip
sys-devel/gdb: fix build with USE=-nls
* add f to rm -r for when locale dir is not there Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-8.0.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-8.0.1.ebuild b/sys-devel/gdb/gdb-8.0.1.ebuild
index 82cbc96263c0..6e1aa11c9e28 100644
--- a/sys-devel/gdb/gdb-8.0.1.ebuild
+++ b/sys-devel/gdb/gdb-8.0.1.ebuild
@@ -178,7 +178,7 @@ src_test() {
}
src_install() {
- if use server && ! use client; then
+ if use server && ! use client; then
cd gdb/gdbserver || die
fi
default
@@ -197,7 +197,7 @@ src_install() {
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${ED}"/usr/share/{doc,info,locale} || die
+ rm -rf "${ED}"/usr/share/{doc,info,locale} || die
local f
for f in "${ED}"/usr/share/man/*/* ; do
if [[ ${f##*/} != ${CTARGET}-* ]] ; then