summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 17:20:26 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 17:20:41 +0200
commit2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c (patch)
tree8abb89b1b21f48d4f9840064d4050242cece354a /sys-devel/llvm
parentmail-filter/rspamd: version bump to 1.3.5 (fixes bug 593020, bug 592966) (diff)
downloadgentoo-2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c.tar.gz
gentoo-2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c.tar.bz2
gentoo-2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c.zip
sys-devel/llvm: fix patches for 3.4.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch (renamed from sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch (renamed from sys-devel/llvm/files/clang-3.4-gentoo-install.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch (renamed from sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/gentoo-install.patch (renamed from sys-devel/llvm/files/llvm-3.4-gentoo-install.patch)0
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild12
5 files changed, 6 insertions, 6 deletions
diff --git a/sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch b/sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch
index 113b04bc6637..113b04bc6637 100644
--- a/sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch
diff --git a/sys-devel/llvm/files/clang-3.4-gentoo-install.patch b/sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch
index 0a1d9eb3c353..0a1d9eb3c353 100644
--- a/sys-devel/llvm/files/clang-3.4-gentoo-install.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch
diff --git a/sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch b/sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
index 49f108533404..49f108533404 100644
--- a/sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
diff --git a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch b/sys-devel/llvm/files/3.4.2/gentoo-install.patch
index a2ba7dee47ed..a2ba7dee47ed 100644
--- a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch
+++ b/sys-devel/llvm/files/3.4.2/gentoo-install.patch
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index 5e73596754a7..0f5e951dbdcd 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -84,16 +84,16 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
- epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
+ epatch "${FILESDIR}"/3.6.2/nodoctargz.patch
+ epatch "${FILESDIR}"/3.4.2/gentoo-install.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_build_fix.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-install.patch
+ epatch "${FILESDIR}"/3.4.2/clang/darwin_build_fix.patch
+ epatch "${FILESDIR}"/3.9.0/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi