summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-15 10:48:08 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-15 10:53:42 +0200
commit96205dfbd1d850e3845e6b6a9bb058c1c38f79e4 (patch)
treeb87cfc70bbb664e687273d8c4eaf9e8a170efce0 /sys-devel/llvm
parentsys-kernel/rt-sources: version bump to 4.9.20_p16 and remove old (diff)
downloadgentoo-96205dfbd1d850e3845e6b6a9bb058c1c38f79e4.tar.gz
gentoo-96205dfbd1d850e3845e6b6a9bb058c1c38f79e4.tar.bz2
gentoo-96205dfbd1d850e3845e6b6a9bb058c1c38f79e4.zip
sys-devel/llvm: Remove no-longer-useful check-reqs
Now that LLVM is split, the package is no longer horribly large in regular builds. The new sizes fit the usual limits and so do not need specific checks. Furthermore, maintaining all those values with different USE flags and compiler flags combinations.
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-4.0.0-r2.ebuild45
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild45
2 files changed, 4 insertions, 86 deletions
diff --git a/sys-devel/llvm/llvm-4.0.0-r2.ebuild b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
index 4e23b863f25..a61ba7cfb94 100644
--- a/sys-devel/llvm/llvm-4.0.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
@@ -8,8 +8,8 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit check-reqs cmake-utils flag-o-matic \
- multilib-minimal pax-utils python-any-r1 toolchain-funcs versionator
+inherit cmake-utils flag-o-matic multilib-minimal pax-utils \
+ python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -76,48 +76,7 @@ python_check_deps() {
|| has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-check_space() {
- # in megs
- # !debug !multitarget -O2 400
- # !debug multitarget -O2 550
- # debug multitarget -O2 5G
-
- local build_size=550
-
- if use debug; then
- ewarn "USE=debug is known to increase the size of package considerably"
- ewarn "and cause the tests to fail."
- ewarn
-
- (( build_size *= 14 ))
- elif is-flagq '-g?(gdb)?([1-9])'; then
- ewarn "The C++ compiler -g option is known to increase the size of the package"
- ewarn "considerably. If you run out of space, please consider removing it."
- ewarn
-
- (( build_size *= 10 ))
- fi
-
- # Multiply by number of ABIs :).
- local abis=( $(multilib_get_enabled_abis) )
- (( build_size *= ${#abis[@]} ))
-
- local CHECKREQS_DISK_BUILD=${build_size}M
- check-reqs_pkg_pretend
-}
-
-pkg_pretend() {
- check_space
-}
-
-pkg_setup() {
- check_space
-}
-
src_prepare() {
- # Python is needed to run tests using lit
- python_setup
-
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
eapply "${FILESDIR}"/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 2d6aee82423..545cfbbcb49 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -8,8 +8,8 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit check-reqs cmake-utils flag-o-matic git-r3 \
- multilib-minimal pax-utils python-any-r1 toolchain-funcs versionator
+inherit cmake-utils flag-o-matic git-r3 multilib-minimal pax-utils \
+ python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -75,48 +75,7 @@ python_check_deps() {
|| has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-check_space() {
- # in megs
- # !debug !multitarget -O2 400
- # !debug multitarget -O2 550
- # debug multitarget -O2 5G
-
- local build_size=550
-
- if use debug; then
- ewarn "USE=debug is known to increase the size of package considerably"
- ewarn "and cause the tests to fail."
- ewarn
-
- (( build_size *= 14 ))
- elif is-flagq '-g?(gdb)?([1-9])'; then
- ewarn "The C++ compiler -g option is known to increase the size of the package"
- ewarn "considerably. If you run out of space, please consider removing it."
- ewarn
-
- (( build_size *= 10 ))
- fi
-
- # Multiply by number of ABIs :).
- local abis=( $(multilib_get_enabled_abis) )
- (( build_size *= ${#abis[@]} ))
-
- local CHECKREQS_DISK_BUILD=${build_size}M
- check-reqs_pkg_pretend
-}
-
-pkg_pretend() {
- check_space
-}
-
-pkg_setup() {
- check_space
-}
-
src_prepare() {
- # Python is needed to run tests using lit
- python_setup
-
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
eapply "${FILESDIR}"/9999/0007-llvm-config-Clean-up-exported-values-update-for-shar.patch