summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-13 14:49:56 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-13 14:58:45 -0500
commit122399643ea48c64965b0195689e623b30de7499 (patch)
treeaaf34224ee1ca9b07bc0eb957ca50c726122728d /sys-devel/pmake
parentsys-apps/memtest86+: drop old EAPI (diff)
downloadgentoo-122399643ea48c64965b0195689e623b30de7499.tar.gz
gentoo-122399643ea48c64965b0195689e623b30de7499.tar.bz2
gentoo-122399643ea48c64965b0195689e623b30de7499.zip
sys-devel/pmake: drop old EAPI
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/Manifest1
-rw-r--r--sys-devel/pmake/pmake-1.111.3.1.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/sys-devel/pmake/Manifest b/sys-devel/pmake/Manifest
index 48036fba4b58..149a5aafe345 100644
--- a/sys-devel/pmake/Manifest
+++ b/sys-devel/pmake/Manifest
@@ -1,3 +1,2 @@
-DIST pmake_1.111-3.1.debian.tar.gz 32176 BLAKE2B b1e9508a4f14ca856dedca8bf52af119f988b4f1ee50af1170f0afb6c5f1f6a5524cb1debf21e620be59cd8084ae6b1e3becd664ca522b8e04928933a085d0dc SHA512 a5743c0b0478119cf8ac01b0182f14cf213b275078b1cd2badee9ac26a3b40660bf4fd430af079fdaa7bc8117ed8a1cdf855166e34e151204e34e7d2b67beee3
DIST pmake_1.111-3.3.debian.tar.gz 31648 BLAKE2B 31aca433bbeac4275d4c2af0cfd33ef81b0086b0dec107edfc1fba55b15480367ebf62abccd6e2e48f0c7ccc25c59f0b07eed7ac950a5037b73c267b066a9638 SHA512 b22a1d9e371712732f196d91ac3eb9239fa98ee8ee05754576e7a5878cab88976cb10bb6be90706df5ac738373f519468403c23f6a3ff3860a2968b3222a66ed
DIST pmake_1.111.orig.tar.gz 264383 BLAKE2B 54dd510251441b54c9f5d7f6061109b0222191b3acdded1394b51b72b87bbd4255edd80fab46976d92c58929693b6809a9f2c4f001cab8c9cdaabfac9f3adac9 SHA512 ad48708ea014d6a38ad36303504c52992b51a1e815564f1710849d859b1fc3cd58c4a1a71f54ec902c9b69112e9cd1e1a64282ff738439cdb209a4f75c364c22
diff --git a/sys-devel/pmake/pmake-1.111.3.1.ebuild b/sys-devel/pmake/pmake-1.111.3.1.ebuild
deleted file mode 100644
index cbd8c14db38e..000000000000
--- a/sys-devel/pmake/pmake-1.111.3.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs versionator
-
-MY_P="${PN}-$(get_version_component_range 1-2)"
-DEBIAN_SOURCE="${PN}_$(get_version_component_range 1-2).orig.tar.gz"
-DEBIAN_PATCH="${PN}_$(replace_version_separator 2 '-').debian.tar.gz"
-
-DESCRIPTION="BSD build tool to create programs in parallel. Debian's version of NetBSD's make"
-HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="mirror://debian/pool/main/p/pmake/${DEBIAN_SOURCE}
- mirror://debian/pool/main/p/pmake/${DEBIAN_PATCH}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-g0 -E --no-backup-if-mismatch -p1" \
- EPATCH_SUFFIX="diff" \
- epatch "${WORKDIR}/debian/patches"
-
- # pmake makes the assumption that . and .. are the first two
- # entries in a directory, which doesn't always appear to be the
- # case on ext3... (05 Apr 2004 agriffis)
- epatch "${FILESDIR}/${PN}-1.98-skipdots.patch"
-
- # Don't ignore ldflags
- epatch "${FILESDIR}/${PN}-1.111.1-ldflags.patch"
-}
-
-src_compile() {
- # The following CFLAGS are almost directly from Red Hat 8.0 and
- # debian/rules, so assume it's okay to void out the __COPYRIGHT
- # and __RCSID. I've checked the source and don't see the point,
- # but whatever... (07 Feb 2004 agriffis)
- CFLAGS="${CFLAGS} -Wall -Wno-unused -D_GNU_SOURCE \
- -DHAVE_STRERROR -DHAVE_STRDUP -DHAVE_SETENV \
- -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
- -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"$(tc-arch-kernel)\\\" \
- -D_PATH_DEFSHELLDIR=\\\"${EPREFIX}/bin\\\" \
- -D_PATH_DEFSYSPATH=\\\"${EPREFIX}/usr/share/mk\\\" \
- -DHAVE_VSNPRINTF"
- if [[ "${USERLAND}" == "GNU" ]]; then
- CFLAGS="${CFLAGS} -D_PATH_DEFSYSPATH=\\\"${EPREFIX}/usr/share/mk/${PN}\\\""
- fi
-
- emake -f Makefile.boot \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- # Don't install these on BSD, else they conflict
- if [[ "${USERLAND}" == "GNU" ]]; then
- insinto /usr/share/mk/${PN}
- doins mk/*
- fi
-
- newbin bmake pmake
- dobin mkdep
- mv make.1 pmake.1
- doman mkdep.1 pmake.1
- dodoc PSD.doc/tutorial.ms
-
- if [[ "${USERLAND}" == "BSD" ]]; then
- dosym pmake /usr/bin/make
- dosym pmake.1.gz /usr/share/man/man1/make.1.gz
- fi
-}