summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/sparse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/Manifest3
-rw-r--r--sys-devel/sparse/files/sparse-0.4.3-gentoo.patch49
-rw-r--r--sys-devel/sparse/metadata.xml16
-rw-r--r--sys-devel/sparse/sparse-0.4.3.ebuild65
-rw-r--r--sys-devel/sparse/sparse-0.4.4.ebuild47
-rw-r--r--sys-devel/sparse/sparse-0.5.0.ebuild48
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild48
7 files changed, 276 insertions, 0 deletions
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
new file mode 100644
index 000000000000..1331c789b4db
--- /dev/null
+++ b/sys-devel/sparse/Manifest
@@ -0,0 +1,3 @@
+DIST sparse-0.4.3.tar.bz2 172431 SHA256 9059bc649ca8c9309e542d0015091ccf72ac9e3300db0adb4eba838cdcc82f9c SHA512 ff3dbd3e28b1a95dc9d6abf9a4ffdfaa0f470047b8232bd50930839432ae66a2249adb861c880e8eef1a906b007fd7d1c1ef8683c48c763eb523aedc9e1df631 WHIRLPOOL d2fad751e0d9594b467a457843a8beb153d9744683cfe9112ae38484f25eb2bb1784fa58d8ec1c6c5341450e966478e42c16027de271452804e5607c0c393354
+DIST sparse-0.4.4.tar.bz2 174074 SHA256 57ce3b7e33567e67dc0b5c74142aff60a8a78257664a2160c3e3d345d00765af SHA512 5cd5e660ea863170e86f1abaa040434c43a5cc7e92560f1bcbcce9ce906ae7355c066168bfc1dcc551e41e4c0f864122be288ed69eb1c4cda8b7c0825b5b647f WHIRLPOOL 2e61fcbee4e2f603d80db37f69050c130aef9d5df5e43dc475504a29e5d53eed3d599499fc5e3ca9139535f68a7f19e701ee3003f2b20ffe16681ffa524b05d0
+DIST sparse-0.5.0.tar.xz 187576 SHA256 921fcf918c6778d1359f3886ac8cb4cf632faa6242627bc2ae2db75e983488d5 SHA512 0cb70a74034c4bc4d5340ab7d19288a438f4b6d0c4c63ac95d1f4cc3c5fdfe1370a27a607605a6f0c85ea6f371141c55abfdb4438d9e87b2d544fff5674f7ce4 WHIRLPOOL 328027ab5fab473d5819659bb91ab6d655cebc6cf5ec5f5c102217fc11aee5c0e5e56e694260784a315f14b7ce84c25a19b5cd70e98db92cfa9ba19f7e7c8944
diff --git a/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
new file mode 100644
index 000000000000..6f46687d78b3
--- /dev/null
+++ b/sys-devel/sparse/files/sparse-0.4.3-gentoo.patch
@@ -0,0 +1,49 @@
+diff --git a/Makefile b/Makefile
+index 74905df..1f2b2b6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ OS = linux
+
+
+ CC = gcc
+-CFLAGS = -O2 -finline-functions -fno-strict-aliasing -g
++CFLAGS ?= -O2 -finline-functions -fno-strict-aliasing -g
+ CFLAGS += -Wall -Wwrite-strings
+ LDFLAGS += -g
+ AR = ar
+@@ -21,7 +21,8 @@ HAVE_GCC_DEP:=$(shell touch .gcc-test.c && \
+ echo 'yes'; rm -f .gcc-test.d .gcc-test.o .gcc-test.c)
+ HAVE_GTK2:=$(shell pkg-config --exists gtk+-2.0 2>/dev/null && echo 'yes')
+
+-CFLAGS += -DGCC_BASE=\"$(shell $(CC) --print-file-name=)\"
++GCC_BASE = $(shell $(CC) --print-file-name=)
++CFLAGS += -DGCC_BASE=\"$(GCC_BASE)\"
+
+ ifeq ($(HAVE_GCC_DEP),yes)
+ CFLAGS += -Wp,-MD,$(@D)/.$(@F).d
+@@ -113,7 +114,9 @@ SED_PC_CMD = 's|@version@|$(VERSION)|g; \
+
+ all: $(PROGRAMS) sparse.pc
+
+-install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++all-installable: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
++
++install: all-installable
+ $(Q)install -d $(DESTDIR)$(BINDIR)
+ $(Q)install -d $(DESTDIR)$(LIBDIR)
+ $(Q)install -d $(DESTDIR)$(MAN1DIR)
+diff --git a/parse.h b/parse.h
+index 6b21e23..b26bd03 100644
+--- a/parse.h
++++ b/parse.h
+@@ -35,10 +35,6 @@ struct statement {
+ struct /* declaration */ {
+ struct symbol_list *declaration;
+ };
+- struct /* label_arg */ {
+- struct symbol *label;
+- struct statement *label_statement;
+- };
+ struct {
+ struct expression *expression;
+ struct expression *context;
diff --git a/sys-devel/sparse/metadata.xml b/sys-devel/sparse/metadata.xml
new file mode 100644
index 000000000000..8dcee38b5a85
--- /dev/null
+++ b/sys-devel/sparse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <herd>toolchain</herd>
+ <use>
+ <flag name='gtk'>
+ Build the test-inspect utility (requires
+ <pkg>x11-libs/gtk+</pkg> version 2)
+ </flag>
+ <flag name='llvm'>Build the sparse-llvm utility</flag>
+ <flag name='xml'>
+ Build the c2xml utility (requires <pkg>dev-libs/libxml2</pkg>).
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-devel/sparse/sparse-0.4.3.ebuild b/sys-devel/sparse/sparse-0.4.3.ebuild
new file mode 100644
index 000000000000..0190d1bd14c3
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.4.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib flag-o-matic toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.bz2"
+ KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk xml test"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ # http://cgit.gentoo.org/proj/sparse.git
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+mymake() {
+ usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
+
+ emake \
+ V=1 \
+ CC="$(tc-getCC)" \
+ GCC_BASE="$(gcc-config -L | cut -d : -f1)" \
+ HAVE_LIBXML=$(usex xml) \
+ HAVE_GTK2=$(usex gtk) \
+ PREFIX=/usr \
+ LIBDIR="/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ "$@" \
+ || die
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+
+ mymake \
+ $(use test && echo all) all-installable
+}
+
+src_install() {
+ mymake install
+ dodoc FAQ README
+}
diff --git a/sys-devel/sparse/sparse-0.4.4.ebuild b/sys-devel/sparse/sparse-0.4.4.ebuild
new file mode 100644
index 000000000000..87dec030e74f
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git-2
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}
diff --git a/sys-devel/sparse/sparse-0.5.0.ebuild b/sys-devel/sparse/sparse-0.5.0.ebuild
new file mode 100644
index 000000000000..d7539cd1515b
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git-2
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk llvm test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( >=sys-devel/llvm-3.0 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
new file mode 100644
index 000000000000..d7539cd1515b
--- /dev/null
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git-2
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk llvm test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ llvm? ( >=sys-devel/llvm-3.0 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LLVM=$(usex llvm) HAVE_LIBXML=$(usex xml)"
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}