summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-23 00:13:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-23 00:25:14 +0200
commit92f219926eb24aa701151c4c9b938f39163de27a (patch)
treea3377055d3cb072a6e21f32a28727dec0180e07d /sys-devel
parentx11-plugins/gkrellflynn: last rite (diff)
downloadgentoo-92f219926eb24aa701151c4c9b938f39163de27a.tar.gz
gentoo-92f219926eb24aa701151c4c9b938f39163de27a.tar.bz2
gentoo-92f219926eb24aa701151c4c9b938f39163de27a.zip
sys-devel/bison: Bump to version 3.4.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/Manifest2
-rw-r--r--sys-devel/bison/bison-3.4.1.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 68022917cefb..dcc78d4a77a8 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -5,3 +5,5 @@ DIST bison-3.2.4.tar.xz 2094568 BLAKE2B 9b7617b25f1b151c3b86a5f57e733543160fb40f
DIST bison-3.3-patches-01.tar.xz 10768 BLAKE2B 6b4df80d0cf6ff3445019bbc66063b794731d2c9869b20b0ace3ed9500e7ea4a30685a4084717871a68838b31392a90d2e1b52ef01eb2f62ea420e513268652c SHA512 32accc5a9e7b18b8dd98c73e5da50018be68effed9b69ed4d30604c7e7ba4495eef54b7882c3fe32bdeffb9278165ac2b5f3164b7c122e2001e4dd60ac2f4d1a
DIST bison-3.3.1.tar.xz 2106048 BLAKE2B 998ab8cd014e0dde5a9a709ec8505e51ac5a85f3f88eb5c1a8dda7d2f1a8d82fbe6bd75b06b7a8ca3c67072f1ad09997c559a7584c443174165408f6200276ab SHA512 8901a97adda0d6d62c06e85d12645b35fa624c9f05e40250c1bb387d5524ac52c2b7de0402ab970f6ccfaf99c9bb5356873daa20cdd0c37d73b4a6ed7b98c44f
DIST bison-3.3.2.tar.xz 2108612 BLAKE2B 84cf59c02ff4ba34c052ef2539cde8d5932145ab21b63c879eeb32d183cadba6cb6209278090e38f3f03085e58ad1fff71248e5729513d8dffdcc14e8f924dfc SHA512 63c67291ea1bd00f4412fc589ffb891ede3e2577253016a9a185e00fb2d702371f3862486639a8f52f8a887f340a639575ff3b7ba93c152170cbfd8c9585c1dc
+DIST bison-3.4.1-patches-01.tar.xz 10812 BLAKE2B 81311c4de0e70e5ca5861e36918be138d14b52872634e85f7e80e2290dc925154faac0d97b8a7c5b2e3cab973ab2a82627057fc4a078517e393174e3b2fda4fb SHA512 5a0fe975982a307bbdb4197441bc48231f3621a59cc97a896789b2976f80bc87e906dd71e5c81ffa75da2932e2f80fa52c894dc005007b7b319379a824fffcf9
+DIST bison-3.4.1.tar.xz 2198020 BLAKE2B 03369f92959061fd780fcde38d62e81f433ec7c0e6632ddf27bfb48607fdd510aa8e2e9fefd7e130b84972e168ff0762a7bed4f7a817be36c848ec6562357d2d SHA512 544d66bf11c55a69fad613bea429667c587fb0c3774f6894df81cb3c7931a554f79e6b71d6a6e9109e164e524c632127c967877f71328cd0b69a683d29ed128d
diff --git a/sys-devel/bison/bison-3.4.1.ebuild b/sys-devel/bison/bison-3.4.1.ebuild
new file mode 100644
index 000000000000..db1dd26f8961
--- /dev/null
+++ b/sys-devel/bison/bison-3.4.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.4.1-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.1-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.4.1-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}