summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-12 09:37:02 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-12 10:27:00 +0100
commit948cd2f9cd1634732f3e114b8179157a8df6b520 (patch)
treebc7da61eaa0530a4755b41e6f5524c26cf24aba5 /sys-devel
parentapp-shells/posh: Use https for HOMEPAGE (diff)
downloadgentoo-948cd2f9cd1634732f3e114b8179157a8df6b520.tar.gz
gentoo-948cd2f9cd1634732f3e114b8179157a8df6b520.tar.bz2
gentoo-948cd2f9cd1634732f3e114b8179157a8df6b520.zip
sys-devel/llvm: Install missing Fuzzer libraries in 5.0.9999
Bug: https://bugs.gentoo.org/636840
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-5.0.9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-5.0.9999.ebuild b/sys-devel/llvm/llvm-5.0.9999.ebuild
index 9d4b6f4c4e4f..cbd8b43b170c 100644
--- a/sys-devel/llvm/llvm-5.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-5.0.9999.ebuild
@@ -212,6 +212,11 @@ multilib_src_install() {
rm -rf "${ED%/}"/usr/include || die
mv "${ED%/}"/usr/lib/llvm/${SLOT}/include "${ED%/}"/usr/include || die
+ # install fuzzer libraries for clang (cmake rules were added in 6)
+ # https://bugs.gentoo.org/636840
+ into "/usr/lib/llvm/${SLOT}"
+ dolib.a "$(get_libdir)"/libLLVMFuzzer*.a
+
LLVM_LDPATHS+=( "${EPREFIX}/usr/lib/llvm/${SLOT}/$(get_libdir)" )
}