summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-09-27 17:29:45 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-10-10 17:29:39 +0100
commit32958cecf72d3efd9c1c47a239faaba1f17ed26e (patch)
tree6a1a834bb4ff311b3ac1b02994f9fd06cf84f90d /sys-firmware/edk2-bin
parentsys-firmware/edk2-ovmf-bin: Prepare for rename to sys-firmware/edk2-bin (diff)
downloadgentoo-32958cecf72d3efd9c1c47a239faaba1f17ed26e.tar.gz
gentoo-32958cecf72d3efd9c1c47a239faaba1f17ed26e.tar.bz2
gentoo-32958cecf72d3efd9c1c47a239faaba1f17ed26e.zip
sys-firmware/edk2-ovmf-bin: Rename to edk2-bin to support other platforms
The source package now supports other platforms so follow suit. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-firmware/edk2-bin')
-rw-r--r--sys-firmware/edk2-bin/Manifest1
-rw-r--r--sys-firmware/edk2-bin/edk2-bin-202202.ebuild71
-rw-r--r--sys-firmware/edk2-bin/metadata.xml11
3 files changed, 83 insertions, 0 deletions
diff --git a/sys-firmware/edk2-bin/Manifest b/sys-firmware/edk2-bin/Manifest
new file mode 100644
index 000000000000..3acdd51ad6e6
--- /dev/null
+++ b/sys-firmware/edk2-bin/Manifest
@@ -0,0 +1 @@
+DIST edk2-ovmf-202202-1.xpak 2672386 BLAKE2B 75c15d4379610ab2af85b78166e350d52f4f1bc1fff5b2eb693ad0d7b1f6648e65d8ae3e2c5467f93f1557ad3b4fa664ab2d76ff10794667de22c2ea8cca6b2d SHA512 06783b89c96bada0fd025ff39eaee501a027abcb03c0bdcf3ff497d52be22927ab03013d90f145ee94a8662cfffe4f8c154dcd06db1bb1acef8a85ae43de14a3
diff --git a/sys-firmware/edk2-bin/edk2-bin-202202.ebuild b/sys-firmware/edk2-bin/edk2-bin-202202.ebuild
new file mode 100644
index 000000000000..75ae882382d6
--- /dev/null
+++ b/sys-firmware/edk2-bin/edk2-bin-202202.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 secureboot
+
+BINPKG="edk2-ovmf-${PV}-1"
+
+DESCRIPTION="UEFI firmware for 64-bit x86 virtual machines"
+HOMEPAGE="https://github.com/tianocore/edk2"
+SRC_URI="https://dev.gentoo.org/~ajak/distfiles/${BINPKG}.xpak"
+S="${WORKDIR}"
+
+# TODO: the binary 202105 package currently lacks the preseeded
+# OVMF_VARS.secboot.fd file (that we typically get from fedora)
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~loong ~ppc ppc64 ~riscv x86"
+
+RDEPEND="!sys-firmware/edk2"
+
+DISABLE_AUTOFORMATTING=true
+DOC_CONTENTS="This package contains the tianocore edk2 UEFI firmware for 64-bit x86
+virtual machines. The firmware is located under
+ /usr/share/edk2-ovmf/OVMF_CODE.fd
+ /usr/share/edk2-ovmf/OVMF_VARS.fd
+ /usr/share/edk2-ovmf/OVMF_CODE.secboot.fd
+
+If USE=binary is enabled, we also install an OVMF variables file (coming from
+fedora) that contains secureboot default keys
+
+ /usr/share/edk2-ovmf/OVMF_VARS.secboot.fd
+
+If you have compiled this package by hand, you need to either populate all
+necessary EFI variables by hand by booting
+ /usr/share/edk2-ovmf/UefiShell.(iso|img)
+or creating OVMF_VARS.secboot.fd by hand:
+ https://github.com/puiterwijk/qemu-ovmf-secureboot
+
+The firmware does not support csm (due to no free csm implementation
+available). If you need a firmware with csm support you have to download
+one for yourself. Firmware blobs are commonly labeled
+ OVMF{,_CODE,_VARS}-with-csm.fd
+
+In order to use the firmware you can run qemu the following way
+
+ $ qemu-system-x86_64 \\
+ -drive file=/usr/share/edk2-ovmf/OVMF.fd,if=pflash,format=raw,unit=0,readonly=on \\
+ ..."
+
+src_unpack() {
+ tar -xf - < <(xz -c -d --single-stream "${DISTDIR}/${BINPKG}.xpak") || die "unpacking binpkg failed"
+}
+
+src_install() {
+ mv "usr/share/doc/edk2-ovmf-${PV}" "usr/share/doc/${PF}" || die
+
+ # Don't want to try to install the readme from the source package
+ rm "usr/share/doc/${PF}/README.gentoo.bz2"
+ mv usr "${ED}" || die
+
+ secureboot_auto_sign --in-place
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-firmware/edk2-bin/metadata.xml b/sys-firmware/edk2-bin/metadata.xml
new file mode 100644
index 000000000000..674a9e5d13d6
--- /dev/null
+++ b/sys-firmware/edk2-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:tianocore:edk2</remote-id>
+ </upstream>
+</pkgmetadata>