summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-10-10 11:16:20 -0400
committerMike Pagano <mpagano@gentoo.org>2019-10-10 11:16:31 -0400
commit147873f303be20acf22ea1415e9c1795fd681b5c (patch)
treec903786bbd48e3e5c12728f589b4e4a6fe409585 /sys-firmware
parentxfce-extra/xfce4-screensaver: Readd dep on dbus-glib (diff)
downloadgentoo-147873f303be20acf22ea1415e9c1795fd681b5c.tar.gz
gentoo-147873f303be20acf22ea1415e9c1795fd681b5c.tar.bz2
gentoo-147873f303be20acf22ea1415e9c1795fd681b5c.zip
sys-firmware/iwl6050-ucode: EAPI bump and clean-up
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild40
-rw-r--r--sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild35
2 files changed, 46 insertions, 29 deletions
diff --git a/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild b/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild
index 97c8dfc4a23..e3b0b43e03d 100644
--- a/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild
+++ b/sys-firmware/iwl6050-ucode/iwl6050-ucode-41.28.5.1.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=6
inherit linux-info
-MY_PN="iwlwifi-6050-ucode"
+MY_P="iwlwifi-${P#iwl}"
DESCRIPTION="Intel (R) Wireless WiFi Link 6250-AGN ucode"
-HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
-SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_PN}-${PV}.tgz"
+HOMEPAGE="https://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="https://intellinuxwireless.org/iwlwifi/downloads/${MY_P}.tgz"
LICENSE="ipw3945"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/${MY_PN}-${PV}"
+DEPEND=""
+RDEPEND="
+ !sys-kernel/linux-firmware[-savedconfig]
+"
-src_compile() { :; }
+CONFIG_CHECK="~IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
-src_install() {
- insinto /lib/firmware
- doins iwlwifi-6050-5.ucode || die
-
- dodoc README* || die "dodoc failed"
+S="${WORKDIR}/${MY_P}"
+pkg_pretend() {
if kernel_is lt 2 6 37; then
- ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}"
- ewarn "This microcode image requires a kernel >= 2.6.37 or a 2.6.36 "
- ewarn "kernel using >= genpatches-2.6.36-8 which is included"
- ewarn "in gentoo-sources >= 2.6.36-r6 or any kernel version >= 2.6.37."
+ eerror "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ eerror "This microcode image requires a kernel >= 2.6.37."
fi
}
+
+src_install() {
+ insinto /lib/firmware
+ doins iwlwifi-6050-5.ucode
+ dodoc README*
+}
diff --git a/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild b/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild
index 847b3019fea..da558b03962 100644
--- a/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild
+++ b/sys-firmware/iwl6050-ucode/iwl6050-ucode-9.201.4.1.ebuild
@@ -1,26 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=6
-MY_PN="iwlwifi-6050-ucode"
+inherit linux-info
+
+MY_P="iwlwifi-${P#iwl}"
DESCRIPTION="Intel (R) Wireless WiFi Link 6250-AGN ucode"
-HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
-SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_PN}-${PV}.tgz"
+HOMEPAGE="https://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="https://intellinuxwireless.org/iwlwifi/downloads/${MY_P}.tgz"
LICENSE="ipw3945"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-S="${WORKDIR}/${MY_PN}-${PV}"
+DEPEND=""
+RDEPEND="
+ !sys-kernel/linux-firmware[-savedconfig]
+"
+
+CONFIG_CHECK="~IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
-src_compile() { :; }
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 30; then
+ eerror "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ eerror "This microcode image requires a kernel >= 2.6.30."
+ fi
+}
src_install() {
insinto /lib/firmware
- doins iwlwifi-6050-4.ucode || die
-
- dodoc README* || die "dodoc failed"
+ doins iwlwifi-6050-4.ucode
+ dodoc README*
}