summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-08 02:34:53 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-04-08 02:34:53 +0200
commit8b608d093c88360befb75d95468b8d8b680cee5c (patch)
tree9afdd7b015d1bd31153b52798eab7ad7edeec48a /sys-firmware
parentsys-firmware/radeon-ucode: update to latest firmware (diff)
downloadgentoo-8b608d093c88360befb75d95468b8d8b680cee5c.tar.gz
gentoo-8b608d093c88360befb75d95468b8d8b680cee5c.tar.bz2
gentoo-8b608d093c88360befb75d95468b8d8b680cee5c.zip
sys-firmware/amdgpu-ucode: update to latest firmware
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/amdgpu-ucode/Manifest2
-rw-r--r--sys-firmware/amdgpu-ucode/amdgpu-ucode-20160331.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-firmware/amdgpu-ucode/Manifest b/sys-firmware/amdgpu-ucode/Manifest
index 3fe3b392f63f..4c55e1b47e87 100644
--- a/sys-firmware/amdgpu-ucode/Manifest
+++ b/sys-firmware/amdgpu-ucode/Manifest
@@ -1 +1,3 @@
DIST amdgpu-ucode-20150803.tar.xz 735616 SHA256 8854abd0f356159e20e8abe83f66831d4857a98fd0ffc5856deb13d2c5e6d60d SHA512 821fc3ec12bae64bfdc533bba641b9ac3ca96ba2126bc96830e5b8d552ca188c97f35fcd5b601d6b4798e8c0857f67bfd4fcd1c336b4be58d863adf1103b9fa8 WHIRLPOOL 560820c6f4cd261810421e8cdfbdb4f577488c814ab2b94c6d6329420b562cb014e5adc66601c210699260bb57c92b779bca1a21516f711e906f9e6e1f34a033
+DIST amdgpu-ucode-20160331.tar.xz 779248 SHA256 6d97d79b10c46ab6a4dda7fafb1d6d230851cc3ffeb3904007015ee29b7b5c4c SHA512 c8375adcb80d4d0ffc0ebaf5350c7f738d246287f431146638e12541c24b115b604116b16e86a1f63237b2cc8420c6be7e91326b3607a0b3c1cefbd8f3202915 WHIRLPOOL 5d580f62740bbd602ea12a37a88dc2ff3409d329d6c80d3fb9420001732eeba79a5d016ed7571109753ae95538f33e7cd01de94d695ecd11a4d88ebea74cc872
+DIST radeon-ucode-20160331.tar.xz 850404 SHA256 e8641c5d2fb69b24609d4915625083bae912a683514157af73db9363154debef SHA512 d8abc4507798a636f6bb54ae9f76a9a378079d3179b83bbe1540a633d5445a45400ba6a9f460e24a05dcaf1fb6ee66334cddb01cb39f4e59aa969a246510e4eb WHIRLPOOL 63af735154cbe017baf01b36aef9b98a6a6733f116fee0a898c5e5546a1ee8830b752b69e12ba49bebbd41143339520e0afd3905b41039e6b323f247c2521374
diff --git a/sys-firmware/amdgpu-ucode/amdgpu-ucode-20160331.ebuild b/sys-firmware/amdgpu-ucode/amdgpu-ucode-20160331.ebuild
new file mode 100644
index 000000000000..b647c0aa151d
--- /dev/null
+++ b/sys-firmware/amdgpu-ucode/amdgpu-ucode-20160331.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="Microcode for C.Islands/V.Islands/A.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ legacy? ( mirror://gentoo/${P/amdgpu/radeon}.tar.xz )"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="legacy"
+
+RDEPEND="legacy? ( !sys-firmware/radeon-ucode )
+ !>sys-kernel/linux-firmware-20150812[-savedconfig]"
+
+S=${WORKDIR}/${PN}
+
+AMDGPU_LEGACY_CIK="bonaire hawaii kabini kaveri mullins"
+
+src_install() {
+ local chip files legacyfiles
+ if use legacy; then
+ pushd ../radeon_ucode || die
+ for chip in ${AMDGPU_LEGACY_CIK}; do
+ legacyfiles+=( ${chip}*.bin )
+ done
+ insinto /lib/firmware/radeon
+ doins ${legacyfiles[@]}
+ popd
+ fi
+ files=( *.bin )
+ insinto /lib/firmware/amdgpu
+ doins ${files[@]}
+ FILES=( ${files[@]/#/amdgpu/} ${legacyfiles[@]/#/radeon/} )
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_AMDGPU; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has amdgpu DRM built-in but not the microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at https://wiki.gentoo.org/wiki/AMDGPU#Firmware"
+ fi
+ fi
+}