summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-12-24 14:57:28 -0500
committerMike Gilbert <floppym@gentoo.org>2021-12-24 19:02:13 -0500
commitd97e27eba0bcc78cb1ed0d6918a476f19e5976e7 (patch)
tree8798c185e26e093c5e586db2d712425aa63193a3 /sys-fs/eudev
parentprofiles: mask sys-apps/hwids for removal (diff)
downloadgentoo-d97e27eba0bcc78cb1ed0d6918a476f19e5976e7.tar.gz
gentoo-d97e27eba0bcc78cb1ed0d6918a476f19e5976e7.tar.bz2
gentoo-d97e27eba0bcc78cb1ed0d6918a476f19e5976e7.zip
sys-fs/eudev: drop 3.2.10-r1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs/eudev')
-rw-r--r--sys-fs/eudev/Manifest1
-rw-r--r--sys-fs/eudev/eudev-3.2.10-r1.ebuild236
-rw-r--r--sys-fs/eudev/metadata.xml1
3 files changed, 0 insertions, 238 deletions
diff --git a/sys-fs/eudev/Manifest b/sys-fs/eudev/Manifest
index 96e53cf784d9..e963c842d82f 100644
--- a/sys-fs/eudev/Manifest
+++ b/sys-fs/eudev/Manifest
@@ -1,2 +1 @@
-DIST eudev-3.2.10.tar.gz 1961960 BLAKE2B 3708c78fad3abad6aa4b2beaaa325e25e118621aa2e6cb351732f6d8349dc17da9be852cab79045c7a513e927c2d1266c6443814fd264943765d98fb5b404e75 SHA512 d0a076d8a54e9d4ca9ca48cf885d082965144b322950d351b7ead4a5035c2dad6fd66b7f137d7281982876c3c50330cdd5e599788f23e1369388181dd178941d
DIST eudev-3.2.11.tar.gz 2254373 BLAKE2B cfa6235d6509b751fde93ff2b0961b93c3741458e561a7ad9b07b49a57779627532cff25ad3519e5f79320854fcedfcdc23642ef542505cebcd6b2803067389a SHA512 17b328365913af3e434abe667dd0498c3702a41c6cb66f3793ca2c195b05ac06397b0a401077f81df7dd25193e4eeea13657a221ca6cb3d237c4d91e31e30b33
diff --git a/sys-fs/eudev/eudev-3.2.10-r1.ebuild b/sys-fs/eudev/eudev-3.2.10-r1.ebuild
deleted file mode 100644
index 32609688f692..000000000000
--- a/sys-fs/eudev/eudev-3.2.10-r1.ebuild
+++ /dev/null
@@ -1,236 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-KV_min=2.6.39
-
-inherit autotools linux-info multilib multilib-minimal toolchain-funcs
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
-HOMEPAGE="https://github.com/gentoo/eudev"
-
-LICENSE="LGPL-2.1 MIT GPL-2"
-SLOT="0"
-IUSE="+hwdb +kmod introspection rule-generator selinux static-libs test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND=">=sys-apps/util-linux-2.20
- virtual/libcrypt:=
- introspection? ( >=dev-libs/gobject-introspection-1.38 )
- kmod? ( >=sys-apps/kmod-16 )
- selinux? ( >=sys-libs/libselinux-2.1.9 )
- !<sys-libs/glibc-2.11
- !sys-apps/gentoo-systemd-integration
- !sys-apps/systemd"
-DEPEND="${COMMON_DEPEND}
- dev-util/gperf
- virtual/os-headers
- virtual/pkgconfig
- >=sys-devel/make-3.82-r4
- >=sys-kernel/linux-headers-${KV_min}
- test? ( app-text/tree dev-lang/perl )"
-
-RDEPEND="${COMMON_DEPEND}
- acct-group/input
- acct-group/kvm
- acct-group/render
- !<sys-fs/lvm2-2.02.103
- !<sec-policy/selinux-base-2.20120725-r10
- !sys-fs/udev
- !sys-apps/systemd"
-
-PDEPEND=">=sys-fs/udev-init-scripts-26
- hwdb? ( >=sys-apps/hwids-20140304[udev] )"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/udev.h
-)
-
-pkg_pretend() {
- ewarn
- ewarn "As of 2013-01-29, ${P} provides the new interface renaming functionality,"
- ewarn "as described in the URL below:"
- ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
- ewarn
- ewarn "This functionality is enabled BY DEFAULT because eudev has no means of synchronizing"
- ewarn "between the default or user-modified choice of sys-fs/udev. If you wish to disable"
- ewarn "this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules"
- ewarn "exists: touch /etc/udev/rules.d/80-net-name-slot.rules"
- ewarn
-}
-
-pkg_setup() {
- CONFIG_CHECK="~BLK_DEV_BSG ~DEVTMPFS ~!IDE ~INOTIFY_USER ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2 ~SIGNALFD ~EPOLL ~FHANDLE ~NET ~UNIX"
- linux-info_pkg_setup
- get_running_version
-
- # These are required kernel options, but we don't error out on them
- # because you can build under one kernel and run under another.
- if kernel_is lt ${KV_min//./ }; then
- ewarn
- ewarn "Your current running kernel version ${KV_FULL} is too old to run ${P}."
- ewarn "Make sure to run udev under kernel version ${KV_min} or above."
- ewarn
- fi
-}
-
-src_prepare() {
- # change rules back to group uucp instead of dialout for now
- sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules \
- || die "failed to change group dialout to uucp"
-
- eapply_user
- eautoreconf
-}
-
-multilib_src_configure() {
- tc-export CC #463846
- export cc_cv_CFLAGS__flto=no #502950
-
- # Keep sorted by ./configure --help and only pass --disable flags
- # when *required* to avoid external deps or unnecessary compile
- local econf_args
- econf_args=(
- ac_cv_search_cap_init=
- ac_cv_header_sys_capability_h=yes
- DBUS_CFLAGS=' '
- DBUS_LIBS=' '
- --with-rootprefix=
- --with-rootrundir=/run
- --exec-prefix="${EPREFIX}"
- --bindir="${EPREFIX}"/bin
- --includedir="${EPREFIX}"/usr/include
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- --with-rootlibexecdir="${EPREFIX}"/lib/udev
- --enable-split-usr
- --enable-manpages
- --disable-hwdb
- )
-
- # Only build libudev for non-native_abi, and only install it to libdir,
- # that means all options only apply to native_abi
- if multilib_is_native_abi; then
- econf_args+=(
- --with-rootlibdir="${EPREFIX}"/$(get_libdir)
- $(use_enable introspection)
- $(use_enable kmod)
- $(use_enable static-libs static)
- $(use_enable selinux)
- $(use_enable rule-generator)
- )
- else
- econf_args+=(
- --disable-static
- --disable-introspection
- --disable-kmod
- --disable-selinux
- --disable-rule-generator
- )
- fi
- ECONF_SOURCE="${S}" econf "${econf_args[@]}"
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi; then
- emake
- else
- emake -C src/shared
- emake -C src/libudev
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi; then
- emake DESTDIR="${D}" install
- else
- emake -C src/libudev DESTDIR="${D}" install
- fi
-}
-
-multilib_src_test() {
- # make sandbox get out of the way
- # these are safe because there is a fake root filesystem put in place,
- # but sandbox seems to evaluate the paths of the test i/o instead of the
- # paths of the actual i/o that results.
- # also only test for native abi
- if multilib_is_native_abi; then
- addread /sys
- addwrite /dev
- addwrite /run
- default_src_test
- fi
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
-
- insinto /lib/udev/rules.d
- doins "${FILESDIR}"/40-gentoo.rules
-
- use rule-generator && doinitd "${FILESDIR}"/udev-postmount
-}
-
-pkg_postinst() {
- mkdir -p "${EROOT}"run
-
- # "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766
- # So try to remove it here (will only work if empty).
- rmdir "${EROOT}"dev/loop 2>/dev/null
- if [[ -d ${EROOT}dev/loop ]]; then
- ewarn "Please make sure your remove /dev/loop,"
- ewarn "else losetup may be confused when looking for unused devices."
- fi
-
- # REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
- # process it as a list. We only care about the zero case (new install) or the case where
- # the same version is being re-emerged. If there is a second version, allow it to abort.
- local rv rvres=doitnew
- for rv in ${REPLACING_VERSIONS} ; do
- if [[ ${rvres} == doit* ]]; then
- if [[ ${rv%-r*} == ${PV} ]]; then
- rvres=doit
- else
- rvres=${rv}
- fi
- fi
- done
-
- if use hwdb && has_version 'sys-apps/hwids[udev]'; then
- udevadm hwdb --update --root="${ROOT%/}"
-
- # https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- # reload database after it has be rebuilt, but only if we are not upgrading
- # also pass if we are -9999 since who knows what hwdb related changes there might be
- if [[ ${rvres} == doit* ]] && [[ ${ROOT%/} == "" ]] && [[ ${PV} != "9999" ]]; then
- udevadm control --reload
- fi
- fi
- if [[ ${rvres} != doitnew ]]; then
- ewarn
- ewarn "You need to restart eudev as soon as possible to make the"
- ewarn "upgrade go into effect:"
- ewarn "\t/etc/init.d/udev --nodeps restart"
- fi
-
- if use rule-generator && \
- [[ -x $(type -P rc-update) ]] && rc-update show | grep udev-postmount | grep -qsv 'boot\|default\|sysinit'; then
- ewarn
- ewarn "Please add the udev-postmount init script to your default runlevel"
- ewarn "to ensure the legacy rule-generator functionality works as reliably"
- ewarn "as possible."
- ewarn "\trc-update add udev-postmount default"
- fi
-
- elog
- elog "For more information on eudev on Gentoo, writing udev rules, and"
- elog "fixing known issues visit: https://wiki.gentoo.org/wiki/Eudev"
-}
diff --git a/sys-fs/eudev/metadata.xml b/sys-fs/eudev/metadata.xml
index 4ea35bd6e025..859a60f953f6 100644
--- a/sys-fs/eudev/metadata.xml
+++ b/sys-fs/eudev/metadata.xml
@@ -5,7 +5,6 @@
<email>eudev@gentoo.org</email>
</maintainer>
<use>
- <flag name="hwdb">read vendor/device string database and add it to udev database</flag>
<flag name="kmod">enable module loading through libkmod</flag>
<flag name="rule-generator">install legacy rule generator rules and support scripts - note
that the functionality within was dropped from <pkg>sys-fs/udev</pkg> as it is not stable in