summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-07-17 07:49:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-07-17 07:50:03 +0100
commitdc6ed06234f3b129aaa2ea02fe12f773b00a205a (patch)
tree685b6554d8e5a88795988ca672a24b09a40212ae /sys-fs/fuse
parentdev-perl/Perl-Critic-Dynamic: Add dev-perl/CGI into test deps bug #661808 (diff)
downloadgentoo-dc6ed06234f3b129aaa2ea02fe12f773b00a205a.tar.gz
gentoo-dc6ed06234f3b129aaa2ea02fe12f773b00a205a.tar.bz2
gentoo-dc6ed06234f3b129aaa2ea02fe12f773b00a205a.zip
sys-fs/fuse: disable -flto in ~arch ebuilds, bug #663518
Due to https://gcc.gnu.org/PR91186 gcc-9 in -lto mode does not do work parition correctly for symbols introduced with `asm .symver`. That causes linker failures in form of: <artificial>:(.text+0xdafe): undefined reference to `__fuse_read_cmd@' To work it around we filter out -flto flags (already done for masked ebuilds). Bug: https://gcc.gnu.org/PR91186 Closes: https://bugs.gentoo.org/663518 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/fuse-2.9.9-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/sys-fs/fuse/fuse-2.9.9-r1.ebuild b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
new file mode 100644
index 000000000000..49c872088c72
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic libtool linux-info udev toolchain-funcs
+
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+DEPEND="virtual/pkgconfig"
+RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ WARNING_FUSE_FS="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ local PATCHES=( "${FILESDIR}"/${PN}-2.9.3-kernel-types.patch )
+ # sandbox violation with mtab writability wrt #438250
+ # don't sed configure.in without eautoreconf because of maintainer mode
+ sed -i 's:umount --fake:true --fake:' configure || die
+ elibtoolize
+
+ # lto not supported yet -- https://github.com/libfuse/libfuse/issues/198
+ # gcc-9 with -flto leads to link failures: #663518,
+ # https://gcc.gnu.org/PR91186
+ filter-flags -flto*
+
+ default
+}
+
+src_configure() {
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/$(get_udevdir)/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog README.md README.NFS NEWS doc/how-fuse-works doc/kernel.txt )
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+
+ if use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+
+ # installed via fuse-common
+ rm -r "${ED}"/{etc,$(get_udevdir)} || die
+
+ # handled by the device manager
+ rm -r "${D}"/dev || die
+}