summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 13:06:48 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 13:06:48 +0100
commit8e823883f26773f166dcedabc77003b2a4950347 (patch)
treefbaaca0ec2f9e4ee7cd9c0f03b3bfd4ec8870ebc /sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
parentsys-fs/hfsplusutils: Fix GCC 10 (diff)
downloadgentoo-8e823883f26773f166dcedabc77003b2a4950347.tar.gz
gentoo-8e823883f26773f166dcedabc77003b2a4950347.tar.bz2
gentoo-8e823883f26773f166dcedabc77003b2a4950347.zip
sys-fs/hfsplusutils: Use proper `static inline` idiom for gnu89/C11
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild')
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
index a578df335018..34c9cf508cba 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
@@ -3,9 +3,10 @@
EAPI=7
-inherit autotools flag-o-matic
+inherit autotools
MY_P="hfsplus_${PV}"
+
DESCRIPTION="HFS+ Filesystem Access Utilities (a PPC filesystem)"
HOMEPAGE="http://penguinppc.org/historical/hfsplus/"
SRC_URI="http://penguinppc.org/historical/hfsplus/${MY_P}.src.tar.bz2"
@@ -13,7 +14,6 @@ SRC_URI="http://penguinppc.org/historical/hfsplus/${MY_P}.src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc ppc64 x86"
-IUSE="static-libs"
S="${WORKDIR}/hfsplus-${PV}"
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}"/${P}-stdlib.patch
"${FILESDIR}"/${P}-cflags.patch
"${FILESDIR}"/${P}-fno-common-gcc10.patch
+ "${FILESDIR}"/${P}-gcc5.patch
)
src_prepare() {
@@ -36,10 +37,7 @@ src_prepare() {
}
src_configure() {
- # bug 580620
- append-flags -fgnu89-inline
-
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {