summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-27 04:15:37 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-27 04:17:47 -0500
commit05f7d5800a01f9e3f77efff3a6ebbef91cd38042 (patch)
tree5c573455b37c26194fc8a3a13e5577b1d8b29def /sys-fs
parentapp-emacs/ddskk: install skk-setup.el (diff)
downloadgentoo-05f7d5800a01f9e3f77efff3a6ebbef91cd38042.tar.gz
gentoo-05f7d5800a01f9e3f77efff3a6ebbef91cd38042.tar.bz2
gentoo-05f7d5800a01f9e3f77efff3a6ebbef91cd38042.zip
sys-fs/squashfs-tools: add USE=debug support for internal tool tracing
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild3
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild
index 047b87476a49..ee38c952774c 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/squashfs/squashfs${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="lz4 lzma lzo static xattr +xz"
+IUSE="debug lz4 lzma lzo static xattr +xz"
LIB_DEPEND="sys-libs/zlib[static-libs(+)]
!xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
@@ -53,6 +53,7 @@ src_configure() {
)
tc-export CC
+ use debug && append-cppflags -DSQUASHFS_TRACE
use static && append-ldflags -static
}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
index 7815a957ec26..b2c2c5a39252 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
@@ -16,7 +16,7 @@ EGIT_REPO_URI="
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="lz4 lzma lzo static xattr +xz"
+IUSE="debug lz4 lzma lzo static xattr +xz"
LIB_DEPEND="sys-libs/zlib[static-libs(+)]
!xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
@@ -50,6 +50,7 @@ src_configure() {
)
tc-export CC
+ use debug && append-cppflags -DSQUASHFS_TRACE
use static && append-ldflags -static
}