summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-10-20 20:56:08 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-10-20 20:56:34 +0200
commit0e5508a380821c3e0833ad4418325284df741a69 (patch)
tree81663feb722c97f7755fd3b5cd79462d7d6ac496 /sys-fs
parentx11-misc/notify-osd: Needs dev-util/glib-utils (diff)
downloadgentoo-0e5508a380821c3e0833ad4418325284df741a69.tar.gz
gentoo-0e5508a380821c3e0833ad4418325284df741a69.tar.bz2
gentoo-0e5508a380821c3e0833ad4418325284df741a69.zip
sys-fs/xfsprogs: Static build is not possible anymore, bug 666196
Dropping static useflag. Closes: https://bugs.gentoo.org/666196 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild13
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild15
2 files changed, 7 insertions, 21 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
index 4231d192e3fd..536041bd17a0 100644
--- a/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
@@ -12,20 +12,15 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ~arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sh ~sparc x86"
-IUSE="icu libedit nls readline static static-libs"
-REQUIRED_USE="static? ( static-libs )"
+IUSE="icu libedit nls readline static-libs"
LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
icu? ( dev-libs/icu:=[static-libs(+)] )
readline? ( sys-libs/readline:0=[static-libs(+)] )
!readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
!<sys-fs/xfsdump-3"
DEPEND="${RDEPEND}
- static? (
- ${LIB_DEPEND}
- readline? ( sys-libs/ncurses:0=[static-libs] )
- )
nls? ( sys-devel/gettext )"
PATCHES=(
@@ -44,11 +39,9 @@ pkg_setup() {
src_prepare() {
default
- # LLDFLAGS is used for programs, so apply -all-static when USE=static is enabled.
# Clear out -static from all flags since we want to link against dynamic xfs libs.
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e "1iLLDFLAGS += $(usex static '-all-static' '')" \
include/builddefs.in || die
find -name Makefile -exec \
sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
@@ -77,7 +70,7 @@ src_configure() {
$(use_enable readline)
$(usex readline --disable-editline $(use_enable libedit editline))
)
- if use static || use static-libs ; then
+ if use static-libs ; then
myconf+=( --enable-static )
else
myconf+=( --disable-static )
diff --git a/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild b/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild
index 273db91aea0b..679012764c95 100644
--- a/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,20 +12,15 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="icu libedit nls readline static static-libs"
-REQUIRED_USE="static? ( static-libs )"
+IUSE="icu libedit nls readline static-libs"
LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
icu? ( dev-libs/icu:=[static-libs(+)] )
readline? ( sys-libs/readline:0=[static-libs(+)] )
!readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
!<sys-fs/xfsdump-3"
DEPEND="${RDEPEND}
- static? (
- ${LIB_DEPEND}
- readline? ( sys-libs/ncurses:0=[static-libs] )
- )
nls? ( sys-devel/gettext )"
PATCHES=(
@@ -44,11 +39,9 @@ pkg_setup() {
src_prepare() {
default
- # LLDFLAGS is used for programs, so apply -all-static when USE=static is enabled.
# Clear out -static from all flags since we want to link against dynamic xfs libs.
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e "1iLLDFLAGS += $(usex static '-all-static' '')" \
include/builddefs.in || die
find -name Makefile -exec \
sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
@@ -77,7 +70,7 @@ src_configure() {
$(use_enable readline)
$(usex readline --disable-editline $(use_enable libedit editline))
)
- if use static || use static-libs ; then
+ if use static-libs ; then
myconf+=( --enable-static )
else
myconf+=( --disable-static )