summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-06-04 14:41:34 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-06-04 14:41:58 -0500
commit58ccc76d8de97788e9ebc3e0e2ceb3f60e2be940 (patch)
tree46251ff37fbad3abbb2d2b7f3fc342546fb4d949 /sys-fs
parentdev-libs/botan: version bump (diff)
downloadgentoo-58ccc76d8de97788e9ebc3e0e2ceb3f60e2be940.tar.gz
gentoo-58ccc76d8de97788e9ebc3e0e2ceb3f60e2be940.tar.bz2
gentoo-58ccc76d8de97788e9ebc3e0e2ceb3f60e2be940.zip
sys-fs/udev: sync live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/udev-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 6f250766b546..0d540b35a551 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools bash-completion-r1 eutils linux-info multilib multilib-minimal toolchain-funcs udev user versionator
+inherit autotools bash-completion-r1 linux-info multilib multilib-minimal toolchain-funcs udev user versionator
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
@@ -14,8 +14,8 @@ else
SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
if [[ -n "${patchset}" ]]; then
SRC_URI+="
- https://dev.gentoo.org/~ssuominen/${P}-patches-${patchset}.tar.xz
- https://dev.gentoo.org/~williamh/dist/${P}-patches-${patchset}.tar.xz"
+ https://dev.gentoo.org/~williamh/dist/${P}-patches-${patchset}.tar.xz
+ https://dev.gentoo.org/~ssuominen/${P}-patches-${patchset}.tar.xz"
fi
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -112,7 +112,7 @@ src_prepare() {
# backport some patches
if [[ -n "${patchset}" ]]; then
- EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
+ eapply "${WORKDIR}"/patch
fi
cat <<-EOF > "${T}"/40-gentoo.rules
@@ -128,7 +128,7 @@ src_prepare() {
echo 'AC_DEFUN([AM_PATH_LIBGCRYPT],[:])' > m4/gcrypt.m4
# apply user patches
- epatch_user
+ eapply_user
eautoreconf