summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-23 21:27:21 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-23 21:48:22 +0100
commit704f2dedeb4f78f0cdeae74ddcaf0821db73ca84 (patch)
treeed8bcbd21a87d510c731eaa473547bd485df2ff9 /sys-fs
parentnet-libs/libnsl: Bump to v1.2.0 (diff)
downloadgentoo-704f2dedeb4f78f0cdeae74ddcaf0821db73ca84.tar.gz
gentoo-704f2dedeb4f78f0cdeae74ddcaf0821db73ca84.tar.bz2
gentoo-704f2dedeb4f78f0cdeae74ddcaf0821db73ca84.zip
sys-fs/multipath-tools: Bump to v0.7.4
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch17
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.7.4.ebuild96
3 files changed, 114 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index e732cfda8c44..ebd40ad948d4 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -3,3 +3,4 @@ DIST multipath-tools-0.6.4.tar.gz 285448 SHA256 1e2747883320f7db854201e5bfb97216
DIST multipath-tools-0.7.1.tar.gz 329008 SHA256 d788aaf3ea862b44b5aa07eaa0e5696061f972a1a46d0f469c4a4f4c477c1970 SHA512 81ceb3887250a691b94cb49b7141ace4fc1f69d7f8381e517560dfc7c51ee4c5a1f4f4e40a0b368cf5f7381697fa746b856cbade8990c1608cbcd77248946a82 WHIRLPOOL 2bcc7cc2f425ca3f3f634807cafb7817b54b83d82987a09c9dd530dca1375175a7d52f1854bdd6d5f37c3b1fcf7bc34d67fc2dcae5809dfae968b313c8c86cba
DIST multipath-tools-0.7.2.tar.gz 335187 SHA256 e4273527b8a8e31d596221dd74fdeb9f2b7558d59e514bc7eb040d077bddf24b SHA512 9637e6c69ecfe8dbfb55794569017051961dbe39fa1019000e4be9c2c888a5b6d13ae360af8738bb1fb89a8d27ec833ff0075b1d066b8b3ca21cd9832f477046 WHIRLPOOL 051956ab5c899ce98833925f84245f7450c7c01012edafdb6fff39762cf87908f53413c42f2ccb6059fd2717d29bf55ded260ade027b37ef0227a46b8266d8c7
DIST multipath-tools-0.7.3.tar.gz 344030 SHA256 b59712c3068b9b33c2fc769eb499c637a0ddff7b46ae9d2cc411c4d61e233ffb SHA512 fbcd5609bcb4f80a91410cec86882e9f39ee056edb314382f25db8e1e1ed5c084e14849a67502be2b11a2e980dc2cb5d34235885476ae5ce62809a175bee9ace WHIRLPOOL 03b99202d2831513ba1fcc3e504ba3554b970c5bc366288a50e62e2225028dff972c102b7ae93d026026bea6614b5305a605122c91e0b8deeb91f9c98a68119f
+DIST multipath-tools-0.7.4.tar.gz 350361 BLAKE2B a55a5912f040913b2db8a6fe28727dd52fd4be9ceb8544f1b45384e12112775caa6159da3ce774dd529377796a2b9033490ee655f3caac864919708bdc5070ec SHA512 0a00b79920251b685265ab731e5418538f32d6392b101082c71a6c7345ef7d008bcdcf466ee1317e8bf658d0fb01fc9a2e4ec6658fc565129c1bb5949ac91254
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch b/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch
new file mode 100644
index 000000000000..19573fe6eee6
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.7.4-respect-flags.patch
@@ -0,0 +1,17 @@
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -90,11 +90,12 @@ OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
+ -Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
+ --param=ssp-buffer-size=4
+
+-CFLAGS = $(OPTFLAGS) -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
++CFLAGS ?= $(OPTFLAGS)
++CFLAGS += -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
+ BIN_CFLAGS = -fPIE -DPIE
+ LIB_CFLAGS = -fPIC
+ SHARED_FLAGS = -shared
+-LDFLAGS = -Wl,-z,relro -Wl,-z,now
++LDFLAGS += -Wl,-z,relro -Wl,-z,now
+ BIN_LDFLAGS = -pie
+
+ # Check whether a function with name $1 has been declared in header file $2.
diff --git a/sys-fs/multipath-tools/multipath-tools-0.7.4.ebuild b/sys-fs/multipath-tools/multipath-tools-0.7.4.ebuild
new file mode 100644
index 000000000000..b114189a868b
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.7.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="systemd rbd"
+
+RDEPEND="
+ dev-libs/json-c
+ dev-libs/libaio
+ dev-libs/userspace-rcu
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/udev-171
+ sys-libs/readline:0=
+ rbd? ( sys-cluster/ceph )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.4-respect-flags.patch )
+
+get_systemd_pv() {
+ use systemd && \
+ $(tc-getPKG_CONFIG) --modversion systemd
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix for bug #624884
+ if grep -qF DM_TABLE_STATE kpartx/kpartx.rules ; then
+ sed '/DM_TABLE_STATE/d' -i kpartx/kpartx.rules || die
+ else
+ elog "DM_TABLE_STATE sed hack is no longer necessary."
+ fi
+
+ # The upstream lacks any way to configure the build at present
+ # and ceph is a huge dependency, so we're using sed to make it
+ # optional until the upstream has a proer configure system
+ if ! use rbd ; then
+ sed -i -e "s/libcheckrbd.so/# libcheckrbd.so/" libmultipath/checkers/Makefile
+ sed -i -e "s/-lrados//" libmultipath/checkers/Makefile
+ fi
+}
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man{5,8}
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD=$(get_systemd_pv) \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='${prefix}'/"$(get_udevdir)" \
+ install
+
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}