summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-04-17 13:52:43 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-04-17 13:53:17 -0700
commitb63ebd13296a36b53ba406f2b4037dd7dfa40178 (patch)
tree88ba5b522656d5f45dbaa530f255223b9b1bb404 /sys-fs
parentnet-wireless/gnuradio: update uhd dep (diff)
downloadgentoo-b63ebd13296a36b53ba406f2b4037dd7dfa40178.tar.gz
gentoo-b63ebd13296a36b53ba406f2b4037dd7dfa40178.tar.bz2
gentoo-b63ebd13296a36b53ba406f2b4037dd7dfa40178.zip
sys-fs/ntfs3g: Version bump to 2017.3.23
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/Manifest1
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2017.3.23.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-fs/ntfs3g/Manifest b/sys-fs/ntfs3g/Manifest
index bc29625e14a5..d48f964d5622 100644
--- a/sys-fs/ntfs3g/Manifest
+++ b/sys-fs/ntfs3g/Manifest
@@ -1 +1,2 @@
DIST ntfs-3g_ntfsprogs-2016.2.22.tgz 1264364 SHA256 d7b72c05e4b3493e6095be789a760c9f5f2b141812d5b885f3190c98802f1ea0 SHA512 dbd36fadd2881db1d17fdbf5d2b4e50bbe11dc9dd0ad4917e7f8bc4032c2287346143756ce8754df0d46ce9209f2c0c41b626cad929d76a9bc881712c7101c15 WHIRLPOOL 64630580b70e85f67b31ea7380ff3b6862be0c8cdf6c6af17e9a5eb2fe3f0d5efa7404ad726638ed958fb218631f7006eb492e713c7957d3ce60c6fbb1dd2bb9
+DIST ntfs-3g_ntfsprogs-2017.3.23.tgz 1259054 SHA256 3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5 SHA512 3a607f0d7be35204c992d8931de0404fbc52032c13b4240d2c5e6f285c318a28eb2a385d7cf5ac4cd445876aee5baa5753bb636ada0d870d84a9d3fdbce794ef WHIRLPOOL b1bf327c993aff08b1761a36cff680bccab51d7fb46fc7bb57b0e03a848345307a6d73c3c48118363dbb8eca26abbafded42cb87f853a1ab9b3b38b7af0da715
diff --git a/sys-fs/ntfs3g/ntfs3g-2017.3.23.ebuild b/sys-fs/ntfs3g/ntfs3g-2017.3.23.ebuild
new file mode 100644
index 000000000000..4a9b17c025c2
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2017.3.23.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils linux-info udev toolchain-funcs libtool
+
+MY_PN=${PN/3g/-3g}
+MY_P=${MY_PN}_ntfsprogs-${PV}
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+# The subslot matches the SONAME major #.
+SLOT="0/87"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="acl debug +external-fuse ntfsdecrypt +ntfsprogs static-libs suid xattr"
+
+RDEPEND="!<sys-apps/util-linux-2.20.1-r2
+ !sys-fs/ntfsprogs
+ ntfsdecrypt? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/gnutls-1.4.4
+ )
+ external-fuse? (
+ >=sys-fs/fuse-2.8.0
+ <sys-fs/fuse-3.0.0_pre
+ )"
+DEPEND="${RDEPEND}
+ sys-apps/attr
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS ChangeLog CREDITS README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2014.2.15-no-split-usr.patch
+ "${FILESDIR}"/${PN}-2016.2.22-sysmacros.patch #580136
+)
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ # Keep the symlinks in the same place we put the main binaries.
+ # Having them in / when all the progs are in /usr is pointless.
+ sed -i \
+ -e 's:/sbin:$(sbindir):g' \
+ {ntfsprogs,src}/Makefile.in || die #578336
+ # Note: patches apply to Makefile.in, so don't run autotools here.
+ elibtoolize
+}
+
+src_configure() {
+ tc-ld-disable-gold
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}"/usr \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable ntfsdecrypt crypto) \
+ $(use_enable ntfsprogs) \
+ $(use_enable ntfsprogs quarantined) \
+ --without-uuid \
+ --enable-extras \
+ $(use_enable static-libs static) \
+ --with-fuse=$(usex external-fuse external internal)
+}
+
+src_install() {
+ default
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+ udev_dorules "${FILESDIR}"/99-ntfs3g.rules
+ prune_libtool_files
+
+ dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
+}