summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-08-09 21:45:23 +0200
committerSven Wegener <swegener@gentoo.org>2020-08-09 21:49:32 +0200
commitcb65575f0f19ce79f1c40ff5ef8063d3e3216498 (patch)
treedd3ab1a8423775dc11b949438507d8a967d19542 /sys-kernel/cryptodev
parentnet-misc/stunnel: update r1 init script, add ~arm64 to 5.56-r1 (diff)
downloadgentoo-cb65575f0f19ce79f1c40ff5ef8063d3e3216498.tar.gz
gentoo-cb65575f0f19ce79f1c40ff5ef8063d3e3216498.tar.bz2
gentoo-cb65575f0f19ce79f1c40ff5ef8063d3e3216498.zip
sys-kernel/cryptodev: Update live ebuild to EAPI 7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sys-kernel/cryptodev')
-rw-r--r--sys-kernel/cryptodev/cryptodev-9999.ebuild35
1 files changed, 17 insertions, 18 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-9999.ebuild b/sys-kernel/cryptodev/cryptodev-9999.ebuild
index 97182739422a..08cf07fc623e 100644
--- a/sys-kernel/cryptodev/cryptodev-9999.ebuild
+++ b/sys-kernel/cryptodev/cryptodev-9999.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit linux-info linux-mod
DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
-HOMEPAGE="http://cryptodev-linux.org/index.html"
+HOMEPAGE="http://cryptodev-linux.org/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/cryptodev-linux/cryptodev-linux.git"
S="${WORKDIR}/${PN}-${PV}"
else
- SRC_URI="http://nwl.cc/pub/cryptodev-linux/${PN}-linux-${PV}.tar.gz"
+ SRC_URI="https://github.com/cryptodev-linux/cryptodev-linux/archive/${PN}-linux-${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
- S=${WORKDIR}/${PN}-linux-${PV}
+ S=${WORKDIR}/${PN}-linux-${PN}-linux-${PV}
fi
LICENSE="GPL-2+"
@@ -28,30 +29,28 @@ RESTRICT="test"
MODULE_NAMES="cryptodev(extra:${S})"
BUILD_PARAMS="KERNEL_DIR=\"\${KV_OUT_DIR}\""
+BUILD_TARGETS="build"
pkg_pretend() {
- if use kernel_linux ; then
- CONFIG_CHECK="~CRYPTO ~CRYPTO_BLKCIPHER ~CRYPTO_AEAD"
- check_extra_config
- fi
-}
+ use kernel_linux || die "cryptodev ebuild only support linux"
-pkg_setup() {
- if use kernel_linux ; then
- linux-mod_pkg_setup
+ CONFIG_CHECK="~CRYPTO ~CRYPTO_AEAD"
+ if kernel_is -lt 4 8 0; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_BLKCIPHER"
else
- die "cryptodev ebuild only support linux"
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_SKCIPHER"
fi
- BUILD_TARGETS="build"
- export KERNEL_DIR
+ check_extra_config
}
src_install() {
linux-mod_src_install
+
+ insinto /usr/include/crypto
+ doins crypto/cryptodev.h
+
if use examples ; then
docinto examples
dodoc example/*
fi
- insinto /usr/include/crypto
- doins crypto/cryptodev.h
}