summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-10 12:54:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-13 12:54:24 +0100
commitc71a27d1d6c1936dd41cb8e3b645e68d4b7a08ba (patch)
tree1dfbfd6f3a22ab52551599dc4e4ea3bb12ced867 /sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild
parentapp-misc/fdupes: Synced live ebuild (diff)
downloadgentoo-c71a27d1d6c1936dd41cb8e3b645e68d4b7a08ba.tar.gz
gentoo-c71a27d1d6c1936dd41cb8e3b645e68d4b7a08ba.tar.bz2
gentoo-c71a27d1d6c1936dd41cb8e3b645e68d4b7a08ba.zip
dist-kernel-utils.eclass: Introduce eclass for helper functions
Move some of the utility functions from kernel-install.eclass into dist-kernel-utils.eclass, in order to permit using them without having all kernel-install phases exported. This will be used in order to support rebuilding initramfs in sys-fs/zfs-kmod. Since the eclasses are used only by dist-kernel project eclasses and ebuilds, update the function prefix while moving them. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild')
-rw-r--r--sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild
index 5ba1bd156ea4..f507f70d33cb 100644
--- a/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild
+++ b/sys-kernel/gentoo-kernel-bin/gentoo-kernel-bin-5.4.83-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,7 @@ src_unpack() {
src_test() {
kernel-install_test "${PV}" \
- "${WORKDIR}/usr/src/linux-${PV}/$(kernel-install_get_image_path)" \
+ "${WORKDIR}/usr/src/linux-${PV}/$(dist-kernel_get_image_path)" \
"lib/modules/${PV}"
}