summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-12-18 11:40:45 -0500
committerMike Pagano <mpagano@gentoo.org>2020-12-18 11:40:45 -0500
commit2b2f30c42a60ab75dd5de3cf1d411006f018b6d8 (patch)
treede156325a689c59af3f8dd0ad24fafc24b94ef89 /sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild
parentprofiles/license_groups: add microsoft-edge to @EULA (diff)
downloadgentoo-2b2f30c42a60ab75dd5de3cf1d411006f018b6d8.tar.gz
gentoo-2b2f30c42a60ab75dd5de3cf1d411006f018b6d8.tar.bz2
gentoo-2b2f30c42a60ab75dd5de3cf1d411006f018b6d8.zip
sys-kernel/gentoo-sources: f2fs: fix data corruption bug
Thanks to Stefan de Konink for reporting Closes: https://bugs.gentoo.org/760573 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild
new file mode 100644
index 000000000000..a862c70cea33
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.10.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="3"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}