summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-09-28 05:26:10 -0400
committerMike Pagano <mpagano@gentoo.org>2015-09-28 05:26:10 -0400
commit8c42359c6aec1cc4dee79c9a07b882c72417f1d5 (patch)
treec0218dca118186f9198afdf55749e948bea8c192 /sys-kernel/git-sources
parentsys-devel/clang: fix slot on 3.7.0, thanks klnikita on IRC (diff)
downloadgentoo-8c42359c6aec1cc4dee79c9a07b882c72417f1d5.tar.gz
gentoo-8c42359c6aec1cc4dee79c9a07b882c72417f1d5.tar.bz2
gentoo-8c42359c6aec1cc4dee79c9a07b882c72417f1d5.zip
sys-kernel/git-sources: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.3_rc3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 37238bca0a55..162e54e30100 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-4.2.tar.xz 85507784 SHA256 cf20e044f17588d2a42c8f2a450b0fd84dfdbd579b489d93e9ab7d0e8b45dbeb SHA512 a87bbce3c0c6d810a41bbba1c0dcaae80dc38dded9f8571e97fa4ee5a468d655daf52d260911412f7c7da3171a5114e89d63da14b1753b9a3eb2cc38fd89b9ee WHIRLPOOL 2058e664ee287cc03119ff3dd0155b7018b9c789a13a1012f190e516172f845dcb2d977c8e6a6951e9bd720e5e8cdfa3b888cce392c9b02780520e77475870d0
DIST patch-4.3-rc1.xz 6171956 SHA256 5248a8e4fcf347cd918622b8f17057b50a8c367758fd4aed9b9e9dff0ad6a8d0 SHA512 d5ca7d7aff66305c4ad0b478b670a6c8bc880dfa9ca5e40b2df98eb814c529e18b0b130fe8100747588a02326fbd31d1b3a1b205616368a473e5ce11ee965114 WHIRLPOOL 9529ff348dc69bf224fc38b69dc8edb56ea982443382aadb98f753d16a8b819af04705b94f4a64b219d1584d4800df3b64f0d795842adb35ea01b4547dabc4db
DIST patch-4.3-rc2.xz 6285616 SHA256 b467915f75047d805d5b9da01d416c420aea353321146e52540fcec83c3daeab SHA512 8b218328ac376d7144df179632e839184ef616c3f9f58232cc76155c15852634ddd3a8dcd995395bdd48510d9f4364bc7198e0b9e709754dd74a91c1d46a6799 WHIRLPOOL 8da044d955e1ac9ec78422c853533f071a80680cb5cf914de19858d2cb42cbc25cea857e62b5847f09570a89a96c618389d5cb1f2a35481e4846c57196cd402b
+DIST patch-4.3-rc3.xz 6370684 SHA256 5fb1f48e05e7523223498dcb319cfbdb5de8211713fae3bab17f75239afc13ab SHA512 937352ac6ad4e003938635d9fb3fcb8c8c78268b1f9fb55b09623530391ca9f089b64537422dd7f1a3b0d7bb24bbc0ca896532318067a9e5c1e6904dfef8d65d WHIRLPOOL ea98b91bfefc9f1d3b71c9c3cbf8c2b23ef0a1e3092a05bbe3a7d4dcceb1073e9d361b07bb669fb50e92ae875e230148a66a67c265e6db1ff00c7836bf44e3ed
diff --git a/sys-kernel/git-sources/git-sources-4.3_rc3.ebuild b/sys-kernel/git-sources/git-sources-4.3_rc3.ebuild
new file mode 100644
index 000000000000..13457dbf08c4
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.3_rc3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.2"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}