summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2016-01-04 11:02:48 +0100
committerAgostino Sarubbo <ago@gentoo.org>2016-01-04 11:02:48 +0100
commit994fd2947fdd9011098e68e795d510d9d4029cbf (patch)
treec652c01257769db700877d458d5410a253f9cb96 /sys-kernel/git-sources
parentprofiles: masked =sci-mathematics/reduce-20110414-r1 (diff)
downloadgentoo-994fd2947fdd9011098e68e795d510d9d4029cbf.tar.gz
gentoo-994fd2947fdd9011098e68e795d510d9d4029cbf.tar.bz2
gentoo-994fd2947fdd9011098e68e795d510d9d4029cbf.zip
sys-kernel/git-sources: Automated version bump to 4.4_rc8
Package-Manager: portage-2.2.26 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.4_rc8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 521cf84360e8..3a3337ef8129 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-4.4-rc4.xz 6583896 SHA256 e2a1f4198c0f56b0fb9cdf7056a3efb5c99d117e6c5
DIST patch-4.4-rc5.xz 6618504 SHA256 d976f02cae338d12981c1d9479077379ac7b7b8210fa216549ca24c51b68d85a SHA512 38f1d3b1999374850e7c857d35afeca38d7ae253face09cc689220b38aa0e87a53effcfee13ad6b821a0a7b8a1a9c0ab7a2c0b114d63dbf44f48a41f0c32483f WHIRLPOOL 765f27ca1270a2d3b0d0013a34f71d3891742e57b18f641eacb1ba070abfa8928a7bea7b8e42717ac6568930e83db5c6d113bee40d0a46b17abfb03778b1c42e
DIST patch-4.4-rc6.xz 6663416 SHA256 e4dde89da4c186e16f0af79fb812314a1afb2746349b57831baebb9c762b6c78 SHA512 a8b362c98f76997070e2b8703836c00e5938c37c9c3cf77f4d68c77f78ee5935e305210681c8d45d534027abca249e0b607a57fc4f7df15b756c2a32e4401427 WHIRLPOOL c3e6ba088509c3aa27da021aac74602d90a308d6c66440646ac97a046e644428cd9749d98e3dbcadb9cf6526fb35fea621e83fbd73e1233be8d261060c2d27aa
DIST patch-4.4-rc7.xz 6677688 SHA256 263c181c3d3a53e9bcd501dbc8f8afc6ed8b81f695bc5a670271530f1e671104 SHA512 3895e3a9515f215bdc3f57c9106392dbd19c7ec1b7c360f405b5e203fa1419487781e85416441b14dad46e03c4389d62d0eda18a0a42d26a1a75b47bcb1a81d2 WHIRLPOOL 72d7cd2daea90837ab7e20dc961c50f5e5e77b9a3501ae2ba165d8d0b80656426db6e100243f4555a40301667a63621c127df4b410d814d09c115f469312c5ce
+DIST patch-4.4-rc8.xz 6692052 SHA256 502b516756cb62da6887b680d2f1da211908844c99e3869dd3a1af9f2e9c261e SHA512 875d1954ecf2beff9fe64879d290604958f1f5d7e18cf3cf37327746e2f8175d950a1bc88aec9749d5a753bf1e255ecb4406a63504d7c4738575d86bb27159a9 WHIRLPOOL 24086d6d672ed33f54813476361bdbdd4f90ebf9f10caff8726a8e7a90eb9546482e841249a6ef861987a53333bb2c0c867afe786f7b8c09bcb54ff7b68591da
diff --git a/sys-kernel/git-sources/git-sources-4.4_rc8.ebuild b/sys-kernel/git-sources/git-sources-4.4_rc8.ebuild
new file mode 100644
index 000000000000..5b6ded7aad84
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.4_rc8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.3"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}