summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-01-28 06:27:55 -0500
committerMike Pagano <mpagano@gentoo.org>2019-01-28 06:28:04 -0500
commit9fb086176db510f63122301fd51b0ed0d30acbe8 (patch)
tree950b165161b3aa2148a78a5b4bfebc003591e5c5 /sys-kernel/git-sources
parentnet-fs/samba: Fixed dependency on net-libs/socket_wrapper (diff)
downloadgentoo-9fb086176db510f63122301fd51b0ed0d30acbe8.tar.gz
gentoo-9fb086176db510f63122301fd51b0ed0d30acbe8.tar.bz2
gentoo-9fb086176db510f63122301fd51b0ed0d30acbe8.zip
sys-kernel/git-sources: Linux patch 5.0-rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.58, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.0_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index c196d54ff34d..b286d474558f 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.20.tar.xz 104257836 BLAKE2B fb52cad2897da319299486fa8c3b9415cd0aee0
DIST patch-5.0-rc1.patch 41507244 BLAKE2B 4d66bc2d6be0f84b02a3baaaba02276d3258d713f882ce48973fd93d1ffb3a99505692af61f7e80f18436ee847d542bb0e3fa9f2df727995bf310f08342676da SHA512 811bf8534c4054fad7faa19e0b8513ce3d7f9d515f3e09c4f7767af0d66fba1995261df08ff0c16518e1ed1c966539d9d1e55501e7a89b46773e859241b8ad29
DIST patch-5.0-rc2.patch 41975987 BLAKE2B ddeb47fa996f2f84a9c9f1c81177d09035aceef0447cbe426d494c6a48d6fe9d650cec6776fb3e767d5f1bc0a8bd8a6eb193f598b7b547ee038dfcfe063bc9f3 SHA512 7e615b21a7f1ed3df5a13b84a4e07f5b7c73910f146b86185fd50bb6adb9a87021c7dabefddbe8c1e00e9a8d89dcfa94bf50b8c012bba4c80da05343de8fa77e
DIST patch-5.0-rc3.patch 42400427 BLAKE2B 53a5f97b618168122ac77a16323e45ac501acb2f4a8f4b8d015f4fa31d25874ec98b32b751b3b6ca5857c05cbd876fcabfd57f2616fe55a12b86565288453ca3 SHA512 e5d461982879935633bd0b35e94001a45d2bf71181f86f0871de2697a0aed5c1d19290089feb7eaf919f58c13b61878abcf0403239c66d96d0e7c05a658a99ca
+DIST patch-5.0-rc4.patch 42678556 BLAKE2B 0b1610bb3bd444d70927ed64806ab3dd9e994de0f87c4d00a2b00c24158594b9595901a6943db4e31ebf5058d9587e2133e0a4cb9bde96580dbf0720199353ca SHA512 4a531f46ebdc2ec0f39eaddc3b3362c792e235d591ca58571a9804ac180c546a34cada2c05bcc46828490d0563a0fdebe2b0932bf978f8762340019c61b1afc2
diff --git a/sys-kernel/git-sources/git-sources-5.0_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.0_rc4.ebuild
new file mode 100644
index 000000000000..10cee793e44d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.0_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.20"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}