summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2018-12-17 10:46:05 +0100
committerAgostino Sarubbo <ago@gentoo.org>2018-12-17 10:46:05 +0100
commitce4a76b6f646deaab56e3dab6378aba4b3060cd2 (patch)
tree1d2a048cb64c37d8ae3c2def254c05d117b7df9c /sys-kernel/git-sources
parentsys-kernel/vanilla-sources: Automated version bump to {3.16.62,4.9.146,4.14.8... (diff)
downloadgentoo-ce4a76b6f646deaab56e3dab6378aba4b3060cd2.tar.gz
gentoo-ce4a76b6f646deaab56e3dab6378aba4b3060cd2.tar.bz2
gentoo-ce4a76b6f646deaab56e3dab6378aba4b3060cd2.zip
sys-kernel/git-sources: Automated version bump to 4.20_rc7.
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.20_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 846cf492bf06..2bc619d6910c 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-4.20-rc3.patch 48529229 BLAKE2B 2038039535eaf2e665b37b97d445f04c059a0
DIST patch-4.20-rc4.patch 48770023 BLAKE2B 42f4c2d9e021752708587f582b4b72bfc2d01876e366ca1c8e143e0eb1f7d453408e74246162cbdf0ca8482821e152d51a0ead50154d7d902b6953ce4ee975b3 SHA512 2b16a9deb7e5e8b80bf652e42672f4e60e81b2f6cab6928e8bed15bfd07233970269a6831621827b43b5340f132a25f161d50f503aa80f37014e901437fdea7c
DIST patch-4.20-rc5.patch 49157710 BLAKE2B 81a8c3fdb6b0e9a11e1d23c9f11dd9ab7e9fd021de4c1bc8331c3c07e6ac403111abe1921f69d7011e323f46b9e819e502c5cfb20b3358615b8a6116a5ff4b59 SHA512 1cac308f65df4b4627e836766d2faeb901cbbf4a7193a6097b796f5c179e02a1c07ceab9935a3c4d1d22ec75b46008321cb5e57862ba1bc43579fda2b826b337
DIST patch-4.20-rc6.patch 49410279 BLAKE2B dc81a847dff97700a2fceff11371a8c98e900949467d930d9b602e68b78282fb818bfa527d722d8911fc0f4930f9b7defb2b9dd18ad56405e06ab6fa09288828 SHA512 72412e030699e7079e66062dc0d1ceb91b6ce59ca4b259c58b902bef7935697f5bfbbf4332246b3a082d13765fa7e5c32db114e999bd6011e93f8a9461d8bcec
+DIST patch-4.20-rc7.patch 49521430 BLAKE2B e0b5d51df948dd3baf510b05f062abce79e3a7a189767a8ec56b431b14dc3509064b78602a9537d88112c0ebf5b13197500c3799c8bc845441c01905eef84d1d SHA512 58576ffb3016f6a5948af50bf39eb5ee565d5e0d2866671c08251df48542c819ff3eae4820b5d70286ca16592d32208c8c0bf51e68ea2d76dc7b7d636e39f9ad
diff --git a/sys-kernel/git-sources/git-sources-4.20_rc7.ebuild b/sys-kernel/git-sources/git-sources-4.20_rc7.ebuild
new file mode 100644
index 000000000000..54e27e6f6a7e
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.20_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}