summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-07-30 04:26:50 +0300
committerStefan Strogin <steils@gentoo.org>2019-07-30 04:31:38 +0300
commit6bc01acb15af728e31eb158c23e1e03a0ba31c85 (patch)
treeab1d0c2e2940db3ec4942d6e6dbc591e6482daab /sys-kernel/kpatch
parentnet-dns/dnscrypt-proxy: fix logrotate file (diff)
downloadgentoo-6bc01acb15af728e31eb158c23e1e03a0ba31c85.tar.gz
gentoo-6bc01acb15af728e31eb158c23e1e03a0ba31c85.tar.bz2
gentoo-6bc01acb15af728e31eb158c23e1e03a0ba31c85.zip
sys-kernel/kpatch: add patch to disable DWARF compression
Fixes https://github.com/dynup/kpatch/issues/877 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'sys-kernel/kpatch')
-rw-r--r--sys-kernel/kpatch/files/kpatch-0.7.1-disable-dwarf-compression.patch32
-rw-r--r--sys-kernel/kpatch/kpatch-0.7.1.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-kernel/kpatch/files/kpatch-0.7.1-disable-dwarf-compression.patch b/sys-kernel/kpatch/files/kpatch-0.7.1-disable-dwarf-compression.patch
new file mode 100644
index 000000000000..85f2862df54a
--- /dev/null
+++ b/sys-kernel/kpatch/files/kpatch-0.7.1-disable-dwarf-compression.patch
@@ -0,0 +1,32 @@
+From fe6e3f51bfe17945205445904c1fc602008ac7dd Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Mon, 29 Jul 2019 13:20:20 +0300
+Subject: [PATCH] create-diff-object: disable DWARF compression explicitly
+
+On some systems the linker produces compressed debug sections by
+default. It is not supported by create-diff-object for now.
+
+Fixes: #877
+
+Upstream-Status: Submitted [https://github.com/dynup/kpatch/pull/1011]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ kpatch-build/kpatch-build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kpatch-build/kpatch-build b/kpatch-build/kpatch-build
+index 9ef3809..365655c 100755
+--- a/kpatch-build/kpatch-build
++++ b/kpatch-build/kpatch-build
+@@ -748,7 +748,7 @@ if [[ "$ARCH" = "ppc64le" ]]; then
+ ARCH_KCFLAGS="-mcmodel=large -fplugin=$PLUGINDIR/ppc64le-plugin.so"
+ fi
+
+-export KCFLAGS="-I$DATADIR/patch -ffunction-sections -fdata-sections $ARCH_KCFLAGS"
++export KCFLAGS="-I$DATADIR/patch -ffunction-sections -fdata-sections -gz=none $ARCH_KCFLAGS"
+
+ echo "Reading special section data"
+ find_special_section_data
+--
+2.22.0
+
diff --git a/sys-kernel/kpatch/kpatch-0.7.1.ebuild b/sys-kernel/kpatch/kpatch-0.7.1.ebuild
index dd2b30d0b351..9aa8f4e44e1e 100644
--- a/sys-kernel/kpatch/kpatch-0.7.1.ebuild
+++ b/sys-kernel/kpatch/kpatch-0.7.1.ebuild
@@ -33,6 +33,8 @@ DEPEND="
test? ( dev-util/shellcheck-bin )
"
+PATCHES=( "${FILESDIR}"/${P}-disable-dwarf-compression.patch )
+
pkg_setup() {
if use kmod; then
if kernel_is gt 3 9 0; then