summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-07-29 03:54:39 +0300
committerStefan Strogin <steils@gentoo.org>2019-07-30 04:11:57 +0300
commit6ec6e05b6664d8b236da50c2eaec13c4944df993 (patch)
treece8165c4a29b86cd66760509719489fccfc229ae /sys-kernel/kpatch
parentapp-text/aspell: Bump to version 0.60.7 (diff)
downloadgentoo-6ec6e05b6664d8b236da50c2eaec13c4944df993.tar.gz
gentoo-6ec6e05b6664d8b236da50c2eaec13c4944df993.tar.bz2
gentoo-6ec6e05b6664d8b236da50c2eaec13c4944df993.zip
sys-kernel/kpatch: bump version to 0.7.1
- Install files necessary for kpatch-build into /usr/share/${PN}/patch/ - Remove USE=doc as there is only one not very big document in doc/ and nothing to compile. - Install man pages. - Remove redundant dependency on openssl. Closes: https://bugs.gentoo.org/690912 Closes: https://bugs.gentoo.org/690914 Closes: https://github.com/gentoo/gentoo/pull/12566 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'sys-kernel/kpatch')
-rw-r--r--sys-kernel/kpatch/Manifest1
-rw-r--r--sys-kernel/kpatch/kpatch-0.7.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-kernel/kpatch/Manifest b/sys-kernel/kpatch/Manifest
index 64fabeba9212..575e72f0cd17 100644
--- a/sys-kernel/kpatch/Manifest
+++ b/sys-kernel/kpatch/Manifest
@@ -1 +1,2 @@
DIST kpatch-0.6.3.tar.gz 153100 BLAKE2B e95d1880ffc9ff6038bba98902d0f1e97c9f7f8d0f90eedc281c4bf0570217668cf7b701d038d6f06e9885ebdbb4407cc554d5175cf17eb8fd5051381f75deb3 SHA512 0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06
+DIST kpatch-0.7.1.tar.gz 181732 BLAKE2B da3ff8a6bbd31c3bdc353a3d2b75c6947b915fb309a6f19c57b31a6cbad1d82b9e1611bc2c412c5d049511e217a01719eb9a017d1fbbe7c7bbf2e5b02a381f40 SHA512 c1b149e9532dc16ee4f7578aadf3eda73b53c889a055229490a7afd1fca8e6df755c98c938353f937b81679fe8d08e065c473a6c31e588b1eb67f2de56bfddea
diff --git a/sys-kernel/kpatch/kpatch-0.7.1.ebuild b/sys-kernel/kpatch/kpatch-0.7.1.ebuild
new file mode 100644
index 000000000000..dd2b30d0b351
--- /dev/null
+++ b/sys-kernel/kpatch/kpatch-0.7.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic linux-mod
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
+else
+ SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Dynamic kernel patching for Linux"
+HOMEPAGE="https://github.com/dynup/kpatch"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="contrib +kpatch +kpatch-build kmod test"
+
+RDEPEND="
+ app-crypt/pesign
+ sys-libs/zlib
+ sys-apps/pciutils
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/elfutils
+ sys-devel/bison
+ test? ( dev-util/shellcheck-bin )
+"
+
+pkg_setup() {
+ if use kmod; then
+ if kernel_is gt 3 9 0; then
+ if ! linux_config_exists; then
+ eerror "Unable to check the currently running kernel for kpatch support"
+ eerror "Please be sure a .config file is available in the kernel src dir"
+ eerror "and ensure the kernel has been built."
+ else
+ # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
+ CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
+ ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
+ ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
+ ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
+ ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
+ ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
+ fi
+ else
+ eerror
+ eerror "kpatch is not available for Linux kernels below 4.0.0"
+ eerror
+ die "Upgrade the kernel sources before installing kpatch."
+ fi
+ check_extra_config
+ fi
+
+}
+
+src_prepare() {
+ replace-flags '-O?' '-O1'
+ default
+}
+
+src_compile() {
+ use kpatch-build && emake -C kpatch-build
+ use kpatch && emake -C kpatch
+ use kmod && set_arch_to_kernel && emake -C kmod
+ use contrib && emake -C contrib
+ use test && emake check
+}
+
+src_install() {
+ if use kpatch-build; then
+ emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch-build
+ insinto /usr/share/${PN}/patch
+ doins kmod/patch/kpatch{.lds.S,-macros.h,-patch.h,-patch-hook.c}
+ doins kmod/patch/{livepatch-patch-hook.c,Makefile,patch-hook.c}
+ doins kmod/core/kpatch.h
+ doman man/kpatch-build.1
+ fi
+
+ if use kpatch; then
+ emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch
+ doman man/kpatch.1
+ fi
+
+ use kmod && set_arch_to_kernel && emake DESTDIR="${D}" PREFIX="/usr" install -C kmod
+ use contrib && emake DESTDIR="${D}" PREFIX="/usr" install -C contrib
+
+ dodoc README.md doc/patch-author-guide.md
+}