summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-15 08:19:58 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-15 08:20:30 +0300
commit911289f665e31fe5e1a447842f89fa4506b541f2 (patch)
tree7fe9220610256ccc686d87803c7669f6995f0c6a /sys-kernel/pf-sources
parentprofiles/arch/x86: package.use.mask app-emulation/lxc[apparmor] (diff)
downloadgentoo-911289f665e31fe5e1a447842f89fa4506b541f2.tar.gz
gentoo-911289f665e31fe5e1a447842f89fa4506b541f2.tar.bz2
gentoo-911289f665e31fe5e1a447842f89fa4506b541f2.zip
sys-kernel/pf-sources: bump to 5.6-pf7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.6_p7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 249bbbc3bac1..461784645e64 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -15,3 +15,4 @@ DIST pf-sources-5.6_p3.patch 766739 BLAKE2B 98ab84a2e3c548989c06f6a3fd48fb35c2e5
DIST pf-sources-5.6_p4.patch 848431 BLAKE2B 3313a8bb32b8b6bb79dd222796bd644a62cd792660fd04bff5e749800bbe4145b17d2131c002ebbd9f0ec7879e4527e4d5b7e38a625e3b08f66333920093c3eb SHA512 0df2c8ee0ea4d2aacb6c68e33b1234b0abc68be0a72198f17b59d5f71ff277f61a30e8ab5fbb472674470b4259eec716d8f071b62157248b5b60544e64a87bdb
DIST pf-sources-5.6_p5.patch 861886 BLAKE2B edf1ea471d36a0a2bd715fd8822dfbdad475642ab7896c4583184d8d15d050cdbe7875d12d881f8cc71ccc84149cfda4f20c3f9580d4a87240be5f3fab2c4563 SHA512 b1b560737e20ffe6495c9e87b3ba265d7ba8d494b0572b84db74c76c0de5736e0260c917cb7f43c33a08d611f30e94fe7d438d0cfb9ff05fea0d5bc870eb8665
DIST pf-sources-5.6_p6.patch 1218338 BLAKE2B 4317b9f195fed9e6ed0fee9532a6a878586e501c8e96b584449c18870b966f4e0a105eb3f54f904d1a4aadac3ca67a80d8613c675124ca09dc374d08138083dc SHA512 c760611142a35ddacc8b85520d7de3ed4c69e13abc6775ddd84bcbb58485b5ec5001b1444b858a48c68d4a9f417b4e1a7aab59913e34107987e7897be9bdf97a
+DIST pf-sources-5.6_p7.patch 1519043 BLAKE2B 73ad395b6437920d35a3a695e5adbfa311a4482632e8678daf55ca2e23ed00907be9af725dc1fe44039a66533a74bf98b0bfb15756f7d144ec08d2fc861e8846 SHA512 2d14c4f892433ab95bac2467ac805cb822888d792c005bc266e71a86bbc1131e59dcccee55514cae0d69c2935bbd6ee6bfdbd7bba32e306a8b568423b8d7bab5
diff --git a/sys-kernel/pf-sources/pf-sources-5.6_p7.ebuild b/sys-kernel/pf-sources/pf-sources-5.6_p7.ebuild
new file mode 100644
index 000000000000..e140e5f7329d
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.6_p7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="2"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Temporary fix due to 5.6 iwlwifi mess
+ find "${S}" -name "10*linux*" -delete || die
+
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}