summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-11-22 15:40:50 +0100
committerSam James <sam@gentoo.org>2020-11-23 04:38:36 +0000
commitc3103c6d3aa69ddf8142ba627441edafa39d4c51 (patch)
treedb279cd71ff116406cbbd36ad6c45575f1ec4473 /sys-kernel/raspberrypi-image
parentsys-apps/dbus: Stabilize 1.12.20 ppc, #755392 (diff)
downloadgentoo-c3103c6d3aa69ddf8142ba627441edafa39d4c51.tar.gz
gentoo-c3103c6d3aa69ddf8142ba627441edafa39d4c51.tar.bz2
gentoo-c3103c6d3aa69ddf8142ba627441edafa39d4c51.zip
sys-kernel/raspberrypi-image: Simple bump to 5.4.72_p20201022
Also keep -9999 on par with 5.4.* ebuilds. Closes: https://bugs.gentoo.org/756082 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/18363 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-image')
-rw-r--r--sys-kernel/raspberrypi-image/Manifest1
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-5.4.72_p20201022.ebuild41
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild4
3 files changed, 44 insertions, 2 deletions
diff --git a/sys-kernel/raspberrypi-image/Manifest b/sys-kernel/raspberrypi-image/Manifest
index f0d1c539d140..94ebe470ed03 100644
--- a/sys-kernel/raspberrypi-image/Manifest
+++ b/sys-kernel/raspberrypi-image/Manifest
@@ -1,3 +1,4 @@
DIST raspberrypi-firmware-1.20190925.tar.gz 185571086 BLAKE2B c3a9b2760fa853fbd1dd09bc4048c9e78594f88da5af608c3a761554d4046a4c869db8981c64140a24e82e0a61b8dc776bb8d895df60c6424e44780f78b18cb0 SHA512 4b7b29cc6c2a33d7a37987c492034d9afbb2220364c50cf265e0adf8e5f393c2275dcffaa77c89b3f43b2e98d199741b67590cb60ff8beae8ef677852f63b4a0
DIST raspberrypi-firmware-1.20200902.tar.gz 187144306 BLAKE2B 33a9449fd98fffaa80a9c748f8dd246db491b4f5eb1335ffd10bfacdbe4396c2faabfe522129d287663ad5ef0e9322bd7302a74d6d874e9125f165dc50b81d90 SHA512 91d084d2dba99219b72cc03d49d9546e070477d35fa151b42e204ec6b77ee76a8774235cc32cec8c3aa4360b7c1922dd1c65da8489300476290af87e167f0c79
+DIST raspberrypi-firmware-1.20201022.tar.gz 189827375 BLAKE2B 94c38f60d688c8e3ebab830912daccbb6c04bdd3d88f6ca0d07d85be0a6b12c53f0266b4c258ed4694f30bad5db30fb6d30feabfd0b7668735a9a806b820d325 SHA512 876758179df27109984b6c3f4849fdcdc6bdcc2769495fcc83c97fc3ff4d07b9f3cd58086be877503f72c9e5417d2be6d6c33bce4cbb3b862055117c9cc26db8
DIST raspberrypi-image-4.14.98_p20190215.tar.gz 123074917 BLAKE2B cefedb5c979db7dfd47938aad37a567d91d3ad78247c7a63f789362768ab7a39a1967ac116b4b0475e3b210ab11f6474706df042af85a622e8e7905c85ec7498 SHA512 082f26caf427222d838881e5f1e9fa0136765b3eaf74a84877fc33616fd07e49085db0889226c40c655039a9d41a10566510c7d752cfc48a67b4683616a51193
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.72_p20201022.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.72_p20201022.ebuild
new file mode 100644
index 000000000000..dd284762191f
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.72_p20201022.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+# Temporary safety measure to prevent ending up with a pair of
+# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
+# both of which installed device tree files.
+# Restore to simply "sys-boot/raspberrypi-firmware" when the mentioned version
+# and all older ones are deleted.
+RDEPEND=">sys-boot/raspberrypi-firmware-1.20190709"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm ~arm64"
+fi
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ doins boot/*.img
+
+ doins boot/*.dtb
+ doins -r boot/overlays
+}
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
index 3a9901ac43da..dd284762191f 100644
--- a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,7 @@ else
MY_PV="1.$(ver_cut 5)"
SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
S="${WORKDIR}/firmware-${MY_PV}"
- KEYWORDS="-* ~arm"
+ KEYWORDS="-* ~arm ~arm64"
fi
src_install() {