summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-14 14:04:00 -0500
committerSam James <sam@gentoo.org>2021-03-22 05:21:52 +0000
commit2be341e38bae40dc056de898bca6e2f457432985 (patch)
tree233bfb18c887229b8f43b63ab9805a4155fa111b /sys-kernel/raspberrypi-sources
parentgames-util/xpadneo: fix using KERNEL_DIR as output dir (diff)
downloadgentoo-2be341e38bae40dc056de898bca6e2f457432985.tar.gz
gentoo-2be341e38bae40dc056de898bca6e2f457432985.tar.bz2
gentoo-2be341e38bae40dc056de898bca6e2f457432985.zip
sys-kernel/raspberrypi-sources: fix USE=symlink redux
Previous symlink fix was intended for 5.4.79 but was applied only to 5.10.11 then broken by the source renaming. As a replacement fix, no longer set KV_FULL which works out thanks to the source renaming. Fixes: 13879e90b2639feb21725785ec5070b79e5d8757 Fixes: 40696e5680e8d00928e9ebca1fea5c4ed2035673 Closes: https://bugs.gentoo.org/770460 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.11_p20210201.ebuild11
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild (renamed from sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild)16
2 files changed, 13 insertions, 14 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.11_p20210201.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.11_p20210201.ebuild
index c5517098fc54..1da726507e40 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.11_p20210201.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.11_p20210201.ebuild
@@ -6,19 +6,16 @@ EAPI=6
ETYPE=sources
K_DEFCONFIG="bcmrpi_defconfig"
K_SECURITY_UNSUPPORTED=1
-EXTRAVERSION="-${PN}/-*"
inherit kernel-2 eapi7-ver
detect_version
-detect_arch
-KV_FULL=$(ver_cut 4-)
-KV_FULL="raspberrypi-kernel_1.${KV_FULL/p/}-1"
+MY_P=$(ver_cut 4-)
+MY_P="raspberrypi-kernel_1.${MY_P/p/}-1"
DESCRIPTION="Raspberry Pi kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
-SRC_URI="https://github.com/raspberrypi/linux/archive/${KV_FULL}.tar.gz -> linux-${PV}-raspberrypi.tar.gz"
-S="${WORKDIR}/linux-${PV}-raspberrypi"
+SRC_URI="https://github.com/raspberrypi/linux/archive/${MY_P}.tar.gz -> linux-${KV_FULL}.tar.gz"
KEYWORDS="~arm ~arm64"
@@ -27,5 +24,5 @@ src_unpack() {
# We want to rename the unpacked directory to a nice normalised string
# bug #762766
- mv "${WORKDIR}"/linux-${KV_FULL} "${WORKDIR}"/linux-${PV}-raspberrypi || die
+ mv "${WORKDIR}"/linux-${MY_P} "${WORKDIR}"/linux-${KV_FULL} || die
}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild
index de796c6696ac..9ce67ae0b2a1 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.79_p20201201-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,21 +6,23 @@ EAPI=6
ETYPE=sources
K_DEFCONFIG="bcmrpi_defconfig"
K_SECURITY_UNSUPPORTED=1
-EXTRAVERSION="-${PN}/-*"
inherit kernel-2 eapi7-ver
detect_version
-detect_arch
-MY_PV=$(ver_cut 4-)
-MY_PV=${MY_PV/p/}
+MY_P=$(ver_cut 4-)
+MY_P="raspberrypi-kernel_1.${MY_P/p/}-1"
+
DESCRIPTION="Raspberry Pi kernel sources"
HOMEPAGE="https://github.com/raspberrypi/linux"
-SRC_URI="https://github.com/raspberrypi/linux/archive/raspberrypi-kernel_1.${MY_PV}-1.tar.gz"
-S="${WORKDIR}/linux-raspberrypi-kernel_1.${MY_PV}-1"
+SRC_URI="https://github.com/raspberrypi/linux/archive/${MY_P}.tar.gz"
KEYWORDS="~arm ~arm64"
src_unpack() {
default
+
+ # We want to rename the unpacked directory to a nice normalised string
+ # bug #762766
+ mv "${WORKDIR}"/linux-${MY_P} "${WORKDIR}"/linux-${KV_FULL} || die
}