summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-12-04 22:58:09 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-12-04 23:21:15 +0000
commit8abce41b9c9c5a589af489434b8098a1bd85ecc3 (patch)
treee484184c008ac66f04afbd3a409503db72556b99 /sys-kernel/raspberrypi-sources
parentsys-kernel/raspberrypi-sources: upgrade to EAPI=6 (diff)
downloadgentoo-8abce41b9c9c5a589af489434b8098a1bd85ecc3.tar.gz
gentoo-8abce41b9c9c5a589af489434b8098a1bd85ecc3.tar.bz2
gentoo-8abce41b9c9c5a589af489434b8098a1bd85ecc3.zip
sys-kernel/raspberrypi-sources: add new version 5.4.9999
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.9999.ebuild
new file mode 100644
index 000000000000..9b04c823db71
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.4.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3 eapi7-ver
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(ver_cut 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
+EGIT_CLONE_TYPE="shallow"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}