summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-07 16:15:30 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-05-10 11:12:25 +0200
commitbee02ef44552cfc11ab92323ffbab2c4bec5e977 (patch)
tree7fa86449d78510bac3a2c06f0057c5913f67fb7b /sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild
parentsys-kernel/rt-sources: Add rt-sources for v4.9 LTS (diff)
downloadgentoo-bee02ef44552cfc11ab92323ffbab2c4bec5e977.tar.gz
gentoo-bee02ef44552cfc11ab92323ffbab2c4bec5e977.tar.bz2
gentoo-bee02ef44552cfc11ab92323ffbab2c4bec5e977.zip
sys-kernel/rt-sources: Add rt-sources for v4.4 LTS
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/14858 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild b/sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild
new file mode 100644
index 000000000000..393e767438af
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.4.215_p192.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit eapi7-ver
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT_FULL/g" \
+ -i "${S}/kernel/Kconfig.preempt" || die "sed failed"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."