summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-02-05 11:20:00 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-02-05 11:20:57 +0200
commit4c1b85a73095a0a92c49b7e415d3d76044d5f838 (patch)
tree30c6388dde31e2133762a1866c2238921bd144b0 /sys-kernel
parentx11-terms/kitty: remove old (diff)
downloadgentoo-4c1b85a73095a0a92c49b7e415d3d76044d5f838.tar.gz
gentoo-4c1b85a73095a0a92c49b7e415d3d76044d5f838.tar.bz2
gentoo-4c1b85a73095a0a92c49b7e415d3d76044d5f838.zip
sys-kernel/pf-sources: bump to 5.5-pf2
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.5_p2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 7c954a0360c1..05ec44add300 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -10,3 +10,4 @@ DIST linux-5.5.tar.xz 110713660 BLAKE2B 36b990d3650c409652206c319c93c0cf68885334
DIST pf-sources-5.3_p8.patch 2445607 BLAKE2B d1aa017f43219f661d16e82f9f36ef5b526aad8492f0bb758abda6c1d2caf2d07ed98fd444819dbcc64718c41f0e90b4f18969cafcf02737f1893d92514a49d5 SHA512 033d92493b54fa8bb231f168357cf3b65a7b858e75e04c24a6e97d0dbced7baa8b49cdaec11e4e4b3f2eb44de80a33780511785827dab0893dc1721d47085483
DIST pf-sources-5.4_p6.patch 2445594 BLAKE2B 766549139da27838aca8f849c6d71b13f3b1d1915468d5b617fef243f3947a45e7103d1b48dcf97f81675bf52ef2f15fbaf07ddaae739667ebb82f5b9b604e79 SHA512 9f259d5318fdf81285d2d22cbcdae65691abb8d214d031d74a3889750d027ef5439df1c92e6625ddee51f957c77648ceee7dd9478039a59e6c0b4e02eccede36
DIST pf-sources-5.5_p1.patch 551540 BLAKE2B 6e169f1e3a75a9f18b3c8e8c3ab6da9ff365e8bc467e01e84a088a75a19d4f93908774260569c383479f4e91255abbffb1ea5bc67b955cdb787d1529e50e645f SHA512 8d2a4c71063d741b2e3dfad7403f9c020f9594166554d393d9c5e21d7fa64d20e67b7a91ee6f07dd0db008973b6d0bd88bfad95828ab3a230474770f35377c47
+DIST pf-sources-5.5_p2.patch 657945 BLAKE2B 96acd27211f938605ff14b0588388b78606966e0fdfa7c8168521fd21155db2741d5f8256cb8c5df9232a77a6cf872d2ee945106af5e75502600c45d0d88f660 SHA512 2989554d41c0e970edef4641f7b6a402bd31b48ded6b94fa6b72af356327072a3ea0bcf58b7e9ab953eaf7a555b4cf49dcd75fad58c5da3235f0892f5e06c6ad
diff --git a/sys-kernel/pf-sources/pf-sources-5.5_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.5_p2.ebuild
new file mode 100644
index 000000000000..a86a2780b716
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.5_p2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}