summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2017-10-01 08:44:31 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2017-10-01 08:44:31 +0300
commit52b506bae2f657f6d912fa7f909c6fa05113a55f (patch)
tree09dc958eb82287071d5e54ad2565de9ffd286219 /sys-kernel
parentprofiles: mask media-sound/lastfm-desktop for removal (diff)
downloadgentoo-52b506bae2f657f6d912fa7f909c6fa05113a55f.tar.gz
gentoo-52b506bae2f657f6d912fa7f909c6fa05113a55f.tar.bz2
gentoo-52b506bae2f657f6d912fa7f909c6fa05113a55f.zip
sys-kernel/raspberrypi-sources: Add new versions
Also migrate all to git-r3 eclass Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild4
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild4
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild4
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild27
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild27
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild6
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild4
7 files changed, 65 insertions, 11 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
index 1e0ef374a717..779550859383 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.10.9999.ebuild
@@ -11,7 +11,7 @@ inherit kernel-2
detect_version
detect_arch
-inherit git-2 versionator
+inherit git-r3 versionator
EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
EGIT_PROJECT="raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
@@ -22,6 +22,6 @@ HOMEPAGE="https://github.com/raspberrypi/linux"
KEYWORDS=""
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
unpack_set_extraversion
}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
index 1e0ef374a717..779550859383 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.11.9999.ebuild
@@ -11,7 +11,7 @@ inherit kernel-2
detect_version
detect_arch
-inherit git-2 versionator
+inherit git-r3 versionator
EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
EGIT_PROJECT="raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
@@ -22,6 +22,6 @@ HOMEPAGE="https://github.com/raspberrypi/linux"
KEYWORDS=""
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
unpack_set_extraversion
}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
index 1e0ef374a717..779550859383 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.12.9999.ebuild
@@ -11,7 +11,7 @@ inherit kernel-2
detect_version
detect_arch
-inherit git-2 versionator
+inherit git-r3 versionator
EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
EGIT_PROJECT="raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
@@ -22,6 +22,6 @@ HOMEPAGE="https://github.com/raspberrypi/linux"
KEYWORDS=""
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
unpack_set_extraversion
}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild
new file mode 100644
index 000000000000..779550859383
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.13.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild
new file mode 100644
index 000000000000..779550859383
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.14.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
index fc51687d78b3..779550859383 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ inherit kernel-2
detect_version
detect_arch
-inherit git-2 versionator
+inherit git-r3 versionator
EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
EGIT_PROJECT="raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
@@ -22,6 +22,6 @@ HOMEPAGE="https://github.com/raspberrypi/linux"
KEYWORDS=""
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
unpack_set_extraversion
}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
index 1e0ef374a717..779550859383 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
@@ -11,7 +11,7 @@ inherit kernel-2
detect_version
detect_arch
-inherit git-2 versionator
+inherit git-r3 versionator
EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
EGIT_PROJECT="raspberrypi-linux.git"
EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
@@ -22,6 +22,6 @@ HOMEPAGE="https://github.com/raspberrypi/linux"
KEYWORDS=""
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
unpack_set_extraversion
}