summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-18 10:07:54 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-18 10:08:09 -0500
commita052fd61ac2f9a50128ab32a76daae6e95274802 (patch)
tree7b52fb1edc6804ea4dd0d5fc4aec5f87c57f3560 /sys-libs/efivar
parentmedia-sound/wavpack: Add link to upstream PR in the armv7 patch metadata. (diff)
downloadgentoo-a052fd61ac2f9a50128ab32a76daae6e95274802.tar.gz
gentoo-a052fd61ac2f9a50128ab32a76daae6e95274802.tar.bz2
gentoo-a052fd61ac2f9a50128ab32a76daae6e95274802.zip
sys-libs/efivar: add workaround for GCC_SPECS
Lars Wendler reported a link failure when using a forced as-needed gcc profile. This failure was caused by gcc ignoring the specs file passed on the command line, in favor of the GCC_SPECS environment variable. To work around this, we append the necessary specs file to the envvar. Package-Manager: Portage-2.3.3_p56, Repoman-2.3.1_p49
Diffstat (limited to 'sys-libs/efivar')
-rw-r--r--sys-libs/efivar/efivar-31.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/efivar/efivar-31.ebuild b/sys-libs/efivar/efivar-31.ebuild
index 3dbf6c4f5c67..10cdb3688a7f 100644
--- a/sys-libs/efivar/efivar-31.ebuild
+++ b/sys-libs/efivar/efivar-31.ebuild
@@ -28,4 +28,9 @@ src_configure() {
tc-ld-disable-gold
export libdir="/usr/$(get_libdir)"
unset LIBS # Bug 562004
+
+ if [[ -n ${GCC_SPECS} ]]; then
+ # The environment overrides the command line.
+ GCC_SPECS+=":${S}/gcc.specs"
+ fi
}