summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Šabata <contyk@redhat.com>2021-05-10 08:44:17 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-10 08:22:48 +0100
commit605800519081b08274479cd00dd16a7622e710e5 (patch)
tree70faa30b4f3a459f71ed946ad612e9ef90b11f6e /sys-libs/glibc
parentapp-text/qpdf: x86 stable wrt bug #772794 (diff)
downloadgentoo-605800519081b08274479cd00dd16a7622e710e5.tar.gz
gentoo-605800519081b08274479cd00dd16a7622e710e5.tar.bz2
gentoo-605800519081b08274479cd00dd16a7622e710e5.zip
sys-libs/glibc: Filter "-Wl,--relax" from LDFLAGS
The build fails due to the -r & --relax combination passed to the linker, so let's filter this out. Closes: https://bugs.gentoo.org/788901 Signed-off-by: Petr Šabata <contyk@redhat.com> Closes: https://github.com/gentoo/gentoo/pull/20748 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.33.ebuild4
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.33.ebuild b/sys-libs/glibc/glibc-2.33.ebuild
index 332448bce7bc..8cda845c34b6 100644
--- a/sys-libs/glibc/glibc-2.33.ebuild
+++ b/sys-libs/glibc/glibc-2.33.ebuild
@@ -393,6 +393,10 @@ setup_flags() {
# glibc aborts if rpath is set by LDFLAGS
filter-ldflags '-Wl,-rpath=*'
+ # ld can't use -r & --relax at the same time, bug #788901
+ # https://sourceware.org/PR27837
+ filter-ldflags '-Wl,--relax'
+
# #492892
filter-flags -frecord-gcc-switches
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 7887443a98c7..95493a554e20 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -394,6 +394,10 @@ setup_flags() {
# glibc aborts if rpath is set by LDFLAGS
filter-ldflags '-Wl,-rpath=*'
+ # ld can't use -r & --relax at the same time, bug #788901
+ # https://sourceware.org/PR27837
+ filter-ldflags '-Wl,--relax'
+
# #492892
filter-flags -frecord-gcc-switches