summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/lrmi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/lrmi')
-rw-r--r--sys-libs/lrmi/Manifest1
-rw-r--r--sys-libs/lrmi/files/lrmi-0.10-kernel-2.6.26.patch18
-rw-r--r--sys-libs/lrmi/files/lrmi-0.10-ldflags.patch26
-rw-r--r--sys-libs/lrmi/lrmi-0.10-r1.ebuild37
-rw-r--r--sys-libs/lrmi/metadata.xml8
5 files changed, 90 insertions, 0 deletions
diff --git a/sys-libs/lrmi/Manifest b/sys-libs/lrmi/Manifest
new file mode 100644
index 000000000000..0a1b978a4dc9
--- /dev/null
+++ b/sys-libs/lrmi/Manifest
@@ -0,0 +1 @@
+DIST lrmi-0.10.tar.gz 10271 SHA256 b0be55c14407f586dc10836e8f348b3a002c461a9b47a302071eac0ef85770da
diff --git a/sys-libs/lrmi/files/lrmi-0.10-kernel-2.6.26.patch b/sys-libs/lrmi/files/lrmi-0.10-kernel-2.6.26.patch
new file mode 100644
index 000000000000..9547439376a3
--- /dev/null
+++ b/sys-libs/lrmi/files/lrmi-0.10-kernel-2.6.26.patch
@@ -0,0 +1,18 @@
+diff -Naurp lrmi-0.10-orig/lrmi.c lrmi-0.10/lrmi.c
+--- lrmi-0.10-orig/lrmi.c 2008-08-23 14:39:44.000000000 +0200
++++ lrmi-0.10/lrmi.c 2008-08-23 14:40:25.000000000 +0200
+@@ -61,6 +61,14 @@ OTHER DEALINGS IN THE SOFTWARE.
+
+ #include "lrmi.h"
+
++/* 2.6.26+ kernels don't define the legacy masks. */
++#if defined(__linux__) && !defined(TF_MASK)
++ #define TF_MASK X86_EFLAGS_TF
++ #define IF_MASK X86_EFLAGS_IF
++ #define VIF_MASK X86_EFLAGS_VIF
++ #define IOPL_MASK X86_EFLAGS_IOPL
++#endif
++
+ #define REAL_MEM_BASE ((void *)0x10000)
+ #define REAL_MEM_SIZE 0x40000
+ #define REAL_MEM_BLOCKS 0x100
diff --git a/sys-libs/lrmi/files/lrmi-0.10-ldflags.patch b/sys-libs/lrmi/files/lrmi-0.10-ldflags.patch
new file mode 100644
index 000000000000..b23bd9c5cdf8
--- /dev/null
+++ b/sys-libs/lrmi/files/lrmi-0.10-ldflags.patch
@@ -0,0 +1,26 @@
+diff -Naurp lrmi-0.10-orig/Makefile lrmi-0.10/Makefile
+--- lrmi-0.10-orig/Makefile 2010-08-20 15:03:17.093144820 +0200
++++ lrmi-0.10/Makefile 2010-08-20 15:03:47.761144267 +0200
+@@ -2,6 +2,7 @@ LIBDIR ?= /usr/local/lib
+ INCDIR ?= /usr/local/include
+
+ CFLAGS = -g -Wall
++LDFLAGS =
+
+ sources = lrmi.c
+ objects = lrmi.o
+@@ -26,12 +27,12 @@ liblrmi.a: $(objects)
+
+ liblrmi.so: $(pic_objects)
+ # $(CC) $(CPPFLAGS) $(CFLAGS) -fPIC -shared -o $@ $^
+- $(CC) $(CPPFLAGS) $(CFLAGS) -Wl,-soname,$(LIBNAME).so.$(MAJOR) -fPIC -shared -o $(LIBNAME).so.$(VERSION) $^
++ $(CC) $(CPPFLAGS) $(CFLAGS) -Wl,-soname,$(LIBNAME).so.$(MAJOR) $(LDFLAGS) -fPIC -shared -o $(LIBNAME).so.$(VERSION) $^
+ ln -sf $(LIBNAME).so.$(VERSION) $(LIBNAME).so.$(MAJOR)
+ ln -sf $(LIBNAME).so.$(MAJOR) $(LIBNAME).so
+
+ vbetest: vbetest.c liblrmi.a
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $^
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ install:
+ mkdir -p $(LIBDIR)
diff --git a/sys-libs/lrmi/lrmi-0.10-r1.ebuild b/sys-libs/lrmi/lrmi-0.10-r1.ebuild
new file mode 100644
index 000000000000..80b90c630046
--- /dev/null
+++ b/sys-libs/lrmi/lrmi-0.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="library for calling real mode BIOS routines under Linux"
+HOMEPAGE="http://www.sourceforge.net/projects/lrmi/"
+SRC_URI="mirror://sourceforge/lrmi/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-kernel-2.6.26.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake CFLAGS="${CFLAGS} -Wall" LDFLAGS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin vbetest || die "dobin failed."
+ dolib.a liblrmi.a || die "dolib.a failed."
+ dolib.so liblrmi.so.${PV} || die "dolib.so failed."
+ dosym liblrmi.so.${PV} /usr/lib/liblrmi.so
+ dosym liblrmi.so.${PV} /usr/lib/liblrmi.so.${PV%%.*}
+
+ insinto /usr/include
+ doins lrmi.h vbe.h || die "doins failed."
+}
diff --git a/sys-libs/lrmi/metadata.xml b/sys-libs/lrmi/metadata.xml
new file mode 100644
index 000000000000..c5ea2bc11d70
--- /dev/null
+++ b/sys-libs/lrmi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">lrmi</remote-id>
+ </upstream>
+</pkgmetadata>