summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 01:08:12 +0100
committerSam James <sam@gentoo.org>2022-04-22 01:20:11 +0100
commit6092f05b526be018388afd2490f4c1be6f9101e8 (patch)
treee57878db7698770093cb92d9d672a8fa26460ec7 /sys-libs/obstack-standalone
parentdev-libs/libcec: fix build with musl 1.2.3 (diff)
downloadgentoo-6092f05b526be018388afd2490f4c1be6f9101e8.tar.gz
gentoo-6092f05b526be018388afd2490f4c1be6f9101e8.tar.bz2
gentoo-6092f05b526be018388afd2490f4c1be6f9101e8.zip
sys-libs/obstack-standalone: add 1.2.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/obstack-standalone')
-rw-r--r--sys-libs/obstack-standalone/Manifest1
-rw-r--r--sys-libs/obstack-standalone/obstack-standalone-1.2.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-libs/obstack-standalone/Manifest b/sys-libs/obstack-standalone/Manifest
index 8834b86ea65e..154b3ee1ffa2 100644
--- a/sys-libs/obstack-standalone/Manifest
+++ b/sys-libs/obstack-standalone/Manifest
@@ -1 +1,2 @@
DIST obstack-standalone-1.1.tar.gz 11561 BLAKE2B c6eba8ed7e235dcdefcfa7244d6318c6ac4d4b6d12a8f4778753bbc762ec98439724e1e8bbba4b1a04fbbafe56a1634bbb1c604c4d5f30574da39c82d52ca1c1 SHA512 e3a9956133d72a00663cf8d9720e62002142e113e7d67e2338a2bce1bdfac9eefd4290db8add15eabafdf01065f7fe9bb6754faa36b88df819c53d44fa140757
+DIST obstack-standalone-1.2.3.tar.gz 11483 BLAKE2B fa8322c680fed9f876c90e3182271ec0cf45319ae46c5139613ed1c2f1f268c3361654b55a7a28c2043a7365ea89cefcf3eab2190dadbc1f36c20c203fe97945 SHA512 b2bbed19c4ab2714ca794bdcb1a84fad1af964e884d4f3bbe91c9937ca089d92b8472cb05ebe998a9f5c85cb922b9b458db91eff29077bd099942e1ce18e16cc
diff --git a/sys-libs/obstack-standalone/obstack-standalone-1.2.3.ebuild b/sys-libs/obstack-standalone/obstack-standalone-1.2.3.ebuild
new file mode 100644
index 000000000000..25d82f7cdffc
--- /dev/null
+++ b/sys-libs/obstack-standalone/obstack-standalone-1.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A standalone library to implement GNU libc's obstack"
+HOMEPAGE="https://github.com/void-linux/musl-obstack"
+SRC_URI="https://github.com/void-linux/musl-obstack/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/musl-obstack-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+DEPEND="!sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig/{musl-obstack,obstack-standalone}.pc || die
+}