summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-17 14:39:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-17 14:49:59 +0100
commit5d31720f31d78d74b82bae864fff9bd678d1a217 (patch)
treeacf2a4b0d50393b9f8fb0a83fef05a6f3d9c0f9d /sys-libs/tevent
parentsys-libs/tdb: Bump to version 1.4.3 (diff)
downloadgentoo-5d31720f31d78d74b82bae864fff9bd678d1a217.tar.gz
gentoo-5d31720f31d78d74b82bae864fff9bd678d1a217.tar.bz2
gentoo-5d31720f31d78d74b82bae864fff9bd678d1a217.zip
sys-libs/tevent: Bump to version 0.10.2
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.10.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 00d5e5381f6b..758102f7a4d8 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,5 +1,6 @@
DIST tevent-0.10.0.tar.gz 794845 BLAKE2B 20ed607050b2d558a6ed1cc3b5c7993b711c06bc1eaab6f703db7677b61231d631d49cf82b7a687ae39a4999f4922df4feaecea3b43832983aede0414f316ed1 SHA512 1b55560f2355d98779087046e72528ef30cfbcaf86fc4ad443f405798badc0fc089c8c9ca1e30f90f88f503298c6b39ad968afb0cb088e6035de94d03b8e341f
DIST tevent-0.10.1.tar.gz 804125 BLAKE2B bc124bbf509c0cbf148142ca26312fd74c3bae43792d772b9c21198951ade6740ebac7ca280b0e6aef39fdd4b362f3ac58bfe1610d30119cfff62de6dcd530c5 SHA512 204295672618b8d720743f1d388f9a2d591805c8ef36cdb7e9ae3aa824bc288dab64b336e6a5f5babe6214a993b1ad3d0faa9d8ec2b30a9b927b3ea68bc5fd52
+DIST tevent-0.10.2.tar.gz 800731 BLAKE2B 5ea6b83378b04dbe1666432db0dbd4c0df2e6b0bf5ebcc8ec4ec9bdeb834efec75c87b2019dc78c691aba6c4f6467394101febd6010f106046a1fb8848e27405 SHA512 1da8f28898f35daab515892b880d1de601062cc3e2b2570cd62e6913df17b0195a05acb7b484c628cddc0eb8b0cde893105ede3feb32bc5764e7d25684f332ba
DIST tevent-0.9.31.tar.gz 587784 BLAKE2B 0e562600ae8ba4dae194b1a28a020f5618b1566f65cf2b2f158cd44e6cb30c422086bd2ebfd65a03bc4d4b13de4ca833ff04ab1368255eb2181c148de3487214 SHA512 048e37a7f5d3b8e948215fdb909c9b6e94b915c9d4978a8e18c73c9d27d5b1f179c10d19ec90325f8250e7c177c28231ad116a2975caaa43312c383e75517258
DIST tevent-0.9.37.tar.gz 603859 BLAKE2B 2210416b09c3f83cf68a9f686d1d582891cd22b4547eb0e5237288dca6a0b94619769060c541e0cfc3ccce79246b1140875109934e009015b8e04a31a94d6792 SHA512 5d4833403e1c2f2749f00a389e4757261a4f22cd3a67c906001b36a8b622cc68a38e86d4eb475848a2121ebba054a7e7dac7f486d9f2906a401c3cc97fb447f4
DIST tevent-0.9.38.tar.gz 794856 BLAKE2B 1198de5e68cec39bac3931aa5c26ee26aa5fd713d9cbc72bd90d5dd9c787d617d17c57d8393a845800168452cd8092d38ddc480d3bbe176dfe364d6c9a211094 SHA512 f475a7b7c261368bd641992c8f657c081bbbe783535ff435a7b68f7749d0e5873d57d05cf6ce80a28ccc9f11033022d28e9ae357b03854109c2c279a003d2035
diff --git a/sys-libs/tevent/tevent-0.10.2.ebuild b/sys-libs/tevent/tevent-0.10.2.ebuild
new file mode 100644
index 000000000000..b5a275cd24ef
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.10.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="elibc_glibc python"
+
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ elibc_glibc? (
+ net-libs/libtirpc[${MULTILIB_USEDEP}]
+ || (
+ net-libs/rpcsvc-proto
+ <sys-libs/glibc-2.26[rpc(+)]
+ )
+ )
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}