summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-15 14:51:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-15 15:20:44 +0200
commit967b9d9a2452c9d0792adba76a49bf4787f2ea7b (patch)
tree1b447214359c01dcf15ac7c795f19c46d1994bda /sys-libs/tevent
parentapp-text/qpdf: Removed old (diff)
downloadgentoo-967b9d9a2452c9d0792adba76a49bf4787f2ea7b.tar.gz
gentoo-967b9d9a2452c9d0792adba76a49bf4787f2ea7b.tar.bz2
gentoo-967b9d9a2452c9d0792adba76a49bf4787f2ea7b.zip
sys-libs/tevent: Bump to version 0.10.1
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.10.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 6df16727df3d..4adb4173628a 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,4 +1,5 @@
DIST tevent-0.10.0.tar.gz 794845 BLAKE2B 20ed607050b2d558a6ed1cc3b5c7993b711c06bc1eaab6f703db7677b61231d631d49cf82b7a687ae39a4999f4922df4feaecea3b43832983aede0414f316ed1 SHA512 1b55560f2355d98779087046e72528ef30cfbcaf86fc4ad443f405798badc0fc089c8c9ca1e30f90f88f503298c6b39ad968afb0cb088e6035de94d03b8e341f
+DIST tevent-0.10.1.tar.gz 804125 BLAKE2B bc124bbf509c0cbf148142ca26312fd74c3bae43792d772b9c21198951ade6740ebac7ca280b0e6aef39fdd4b362f3ac58bfe1610d30119cfff62de6dcd530c5 SHA512 204295672618b8d720743f1d388f9a2d591805c8ef36cdb7e9ae3aa824bc288dab64b336e6a5f5babe6214a993b1ad3d0faa9d8ec2b30a9b927b3ea68bc5fd52
DIST tevent-0.9.28.tar.gz 581522 BLAKE2B 95db3ed16b91673ee99fbf30d3c40dfceda080f428feb6b7bbebb0bfc4edc53a183affc8056d25fb05d11a37325b2854949ea5e2dcb170ad7c81e7a7bce62e11 SHA512 328d586a5891796a731e6f0d02e1a731d3541a977c16abca355359cd7f60bbdbb0baaad49c05eb42c3a44f97e57a775605974d22d46ca6c26f283c8ca1b5a909
DIST tevent-0.9.31.tar.gz 587784 BLAKE2B 0e562600ae8ba4dae194b1a28a020f5618b1566f65cf2b2f158cd44e6cb30c422086bd2ebfd65a03bc4d4b13de4ca833ff04ab1368255eb2181c148de3487214 SHA512 048e37a7f5d3b8e948215fdb909c9b6e94b915c9d4978a8e18c73c9d27d5b1f179c10d19ec90325f8250e7c177c28231ad116a2975caaa43312c383e75517258
DIST tevent-0.9.37.tar.gz 603859 BLAKE2B 2210416b09c3f83cf68a9f686d1d582891cd22b4547eb0e5237288dca6a0b94619769060c541e0cfc3ccce79246b1140875109934e009015b8e04a31a94d6792 SHA512 5d4833403e1c2f2749f00a389e4757261a4f22cd3a67c906001b36a8b622cc68a38e86d4eb475848a2121ebba054a7e7dac7f486d9f2906a401c3cc97fb447f4
diff --git a/sys-libs/tevent/tevent-0.10.1.ebuild b/sys-libs/tevent/tevent-0.10.1.ebuild
new file mode 100644
index 000000000000..231bc3b04548
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.10.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="elibc_glibc python"
+
+RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.2.0[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ elibc_glibc? (
+ net-libs/libtirpc[${MULTILIB_USEDEP}]
+ || (
+ net-libs/rpcsvc-proto
+ <sys-libs/glibc-2.26[rpc(+)]
+ )
+ )
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}