summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-14 09:33:09 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-27 09:08:13 +0200
commit0af594f7463019dea259d42d85d8b3c4c4d7bd70 (patch)
tree393a845f8b4ef673411d537b111ec856f73e01b7 /sys-libs
parentvirtual/rubygems: remove ruby22 (diff)
downloadgentoo-0af594f7463019dea259d42d85d8b3c4c4d7bd70.tar.gz
gentoo-0af594f7463019dea259d42d85d8b3c4c4d7bd70.tar.bz2
gentoo-0af594f7463019dea259d42d85d8b3c4c4d7bd70.zip
sys-libs/libselinux: drop explicit ruby22 dependencies
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/libselinux-2.6.ebuild7
-rw-r--r--sys-libs/libselinux/libselinux-2.7.ebuild7
-rw-r--r--sys-libs/libselinux/libselinux-2.8_rc1.ebuild3
-rw-r--r--sys-libs/libselinux/libselinux-2.8_rc2.ebuild3
-rw-r--r--sys-libs/libselinux/libselinux-9999.ebuild5
5 files changed, 10 insertions, 15 deletions
diff --git a/sys-libs/libselinux/libselinux-2.6.ebuild b/sys-libs/libselinux/libselinux-2.6.ebuild
index c92bb50d395..e87f36e1844 100644
--- a/sys-libs/libselinux/libselinux-2.6.ebuild
+++ b/sys-libs/libselinux/libselinux-2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby23"
# No, I am not calling ruby-ng
inherit multilib python-r1 toolchain-funcs multilib-minimal
@@ -27,7 +27,7 @@ fi
LICENSE="public-domain"
SLOT="0"
-IUSE="pcre2 python ruby static-libs ruby_targets_ruby21 ruby_targets_ruby22 ruby_targets_ruby23"
+IUSE="pcre2 python ruby static-libs ruby_targets_ruby23"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
@@ -35,7 +35,6 @@ RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby22? ( dev-lang/ruby:2.2 )
ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
)"
DEPEND="${RDEPEND}
diff --git a/sys-libs/libselinux/libselinux-2.7.ebuild b/sys-libs/libselinux/libselinux-2.7.ebuild
index a8ed808fe47..569190768a0 100644
--- a/sys-libs/libselinux/libselinux-2.7.ebuild
+++ b/sys-libs/libselinux/libselinux-2.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby23"
# No, I am not calling ruby-ng
inherit multilib python-r1 toolchain-funcs multilib-minimal
@@ -27,7 +27,7 @@ fi
LICENSE="public-domain"
SLOT="0"
-IUSE="pcre2 python ruby static-libs ruby_targets_ruby21 ruby_targets_ruby22 ruby_targets_ruby23"
+IUSE="pcre2 python ruby static-libs ruby_targets_ruby23"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
@@ -35,7 +35,6 @@ RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby22? ( dev-lang/ruby:2.2 )
ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
)"
DEPEND="${RDEPEND}
diff --git a/sys-libs/libselinux/libselinux-2.8_rc1.ebuild b/sys-libs/libselinux/libselinux-2.8_rc1.ebuild
index 7fb1b8e7e48..b4d9bf18912 100644
--- a/sys-libs/libselinux/libselinux-2.8_rc1.ebuild
+++ b/sys-libs/libselinux/libselinux-2.8_rc1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby23"
# No, I am not calling ruby-ng
inherit multilib python-r1 toolchain-funcs multilib-minimal
@@ -35,7 +35,6 @@ RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby22? ( dev-lang/ruby:2.2 )
ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
)"
DEPEND="${RDEPEND}
diff --git a/sys-libs/libselinux/libselinux-2.8_rc2.ebuild b/sys-libs/libselinux/libselinux-2.8_rc2.ebuild
index 6c156d54a16..7388fc1ec31 100644
--- a/sys-libs/libselinux/libselinux-2.8_rc2.ebuild
+++ b/sys-libs/libselinux/libselinux-2.8_rc2.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby23"
# No, I am not calling ruby-ng
inherit multilib python-r1 toolchain-funcs multilib-minimal
@@ -35,7 +35,6 @@ RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby22? ( dev-lang/ruby:2.2 )
ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
)"
DEPEND="${RDEPEND}
diff --git a/sys-libs/libselinux/libselinux-9999.ebuild b/sys-libs/libselinux/libselinux-9999.ebuild
index 6c156d54a16..77ada71bdc5 100644
--- a/sys-libs/libselinux/libselinux-9999.ebuild
+++ b/sys-libs/libselinux/libselinux-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby23"
# No, I am not calling ruby-ng
inherit multilib python-r1 toolchain-funcs multilib-minimal
@@ -27,7 +27,7 @@ fi
LICENSE="public-domain"
SLOT="0"
-IUSE="pcre2 python ruby static-libs ruby_targets_ruby21 ruby_targets_ruby22 ruby_targets_ruby23"
+IUSE="pcre2 python ruby static-libs ruby_targets_ruby23"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
@@ -35,7 +35,6 @@ RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby22? ( dev-lang/ruby:2.2 )
ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
)"
DEPEND="${RDEPEND}