summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-03 01:21:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-03 01:21:38 +0200
commit27a7df4094b89c77bcd156b2ad47a40693b21048 (patch)
tree81301d65f663b90e4486dea74169494359aa74e6 /sys-libs
parentwww-client/firefox-bin: bump to v69.0.1 (diff)
downloadgentoo-27a7df4094b89c77bcd156b2ad47a40693b21048.tar.gz
gentoo-27a7df4094b89c77bcd156b2ad47a40693b21048.tar.bz2
gentoo-27a7df4094b89c77bcd156b2ad47a40693b21048.zip
sys-libs/libcap-ng: bump to v0.7.10
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/Manifest1
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.10.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/Manifest b/sys-libs/libcap-ng/Manifest
index dda87749b490..a47182634d14 100644
--- a/sys-libs/libcap-ng/Manifest
+++ b/sys-libs/libcap-ng/Manifest
@@ -1,2 +1,3 @@
+DIST libcap-ng-0.7.10.tar.gz 450243 BLAKE2B 8eb21b0309e46b05fa42752b9c814d90bc1eda4852ac7a4975868c279764431a8d5eafc53e50998470f622e2a59e2b4c6c2ac1ac20525c6fcd0633b09b113012 SHA512 1b93c7f5c20ae5cc705fe5244af3e299454e988388cda95f006e248d97c0713e77da2a81c67ecf15755f3958df373fc6d1ca14197d6357ab1f2d8c3a0fd12def
DIST libcap-ng-0.7.8.tar.gz 447946 BLAKE2B a26af2dcdd1af26cf03ca668dc95eed7bc1d0344729031497f46bba865bcb23ded2f1ea2ca5cb500b9419bbbd7ed75501921485257a3c8930d156a94e0a2c1c1 SHA512 c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756
DIST libcap-ng-0.7.9.tar.gz 449038 BLAKE2B 3f84e5078d5d443cb61358c49405e4f16ff82a56e1c96d5127b522613b1b5c56a566a01b14b40055eca85f13b37f3d795248a506c54ac4612ab184a94addc365 SHA512 095edabaf76a943aab0645b843b14e20b1733ba1d47a8e34d82f6586ca9a1512ba2677d232b13dd3900b913837401bb58bf74481970e967ba19041959dc43259
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.10.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.10.ebuild
new file mode 100644
index 000000000000..e73f7cf226b4
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit autotools flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+src_prepare() {
+ default
+ if use prefix ; then
+ sed -i "s@cat /usr@cat ${EPREFIX}/usr@" bindings/python*/Makefile.am || die
+ eautomake #668722
+ fi
+}
+
+src_configure() {
+ use sparc && replace-flags -O? -O0
+
+ local ECONF_SOURCE="${S}"
+
+ local myconf=(
+ $(use_enable static-libs static)
+ )
+
+ local pythonconf=( --without-python --without-python3 )
+
+ # set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ if python_is_python3; then
+ pythonconf=( --without-python --with-python3 )
+ else
+ pythonconf=( --with-python --without-python3 )
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir emake
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}"
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake check
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}" check
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ else
+ local BUILD_DIR=${WORKDIR}/build
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}