summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-13 18:43:09 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-13 18:43:09 +0100
commit48ccdc1f2319ff1303cd1dc0c9cf8258d3a028f0 (patch)
tree9eb4050e53fb1994cdadcd8dc6436b753abbe35e /sys-libs
parentdev-python/ordereddict: Remove last-rited pkg (diff)
downloadgentoo-48ccdc1f2319ff1303cd1dc0c9cf8258d3a028f0.tar.gz
gentoo-48ccdc1f2319ff1303cd1dc0c9cf8258d3a028f0.tar.bz2
gentoo-48ccdc1f2319ff1303cd1dc0c9cf8258d3a028f0.zip
sys-libs/libcxxrt: Remove last-rited pkg
Closes: https://bugs.gentoo.org/705268 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxrt/Manifest1
-rw-r--r--sys-libs/libcxxrt/files/Makefile23
-rw-r--r--sys-libs/libcxxrt/files/Makefile.test7
-rwxr-xr-xsys-libs/libcxxrt/files/prepare_snapshot.sh16
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild88
-rw-r--r--sys-libs/libcxxrt/libcxxrt-9999.ebuild88
-rw-r--r--sys-libs/libcxxrt/metadata.xml18
7 files changed, 0 insertions, 241 deletions
diff --git a/sys-libs/libcxxrt/Manifest b/sys-libs/libcxxrt/Manifest
deleted file mode 100644
index 1e32270bfa0a..000000000000
--- a/sys-libs/libcxxrt/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libcxxrt-0.0_p20180311.tar.xz 60920 BLAKE2B c75bf5bb88e0f5c448a377a7ae58b33444e644c5e4ce7d6e0f5242c4ee61335be6a8b878bcc06f47bb44f9c48895845b174ca398c95aabb90182ebefd3d31815 SHA512 625aa0fab7d54c584faf4cf1e7f8f694776337fc0c6f441683f035743d00e3d18be3339a8ccfc8b61eb07819e4ccf7b1e5f3e7948fd584eefc5d61b200b32d50
diff --git a/sys-libs/libcxxrt/files/Makefile b/sys-libs/libcxxrt/files/Makefile
deleted file mode 100644
index 18b90a7cf712..000000000000
--- a/sys-libs/libcxxrt/files/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-LIB=cxxrt
-MAJ=1
-OBJS=dynamic_cast.o exception.o guard.o stdexcept.o typeinfo.o memory.o auxhelper.o libelftc_dem_gnu3.o
-SOBJS=${OBJS:.o=.So}
-
-static: lib$(LIB).a
-
-shared: lib$(LIB).so
-
-%.So: %.cc
- $(CXX) -fPIC $(CXXFLAGS) $(CPPFLAGS) -c -o $@ $<
-
-%.So: %.c
- $(CC) -fPIC $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
-
-lib$(LIB).a: $(OBJS)
- $(AR) cr $@ $^
-
-lib$(LIB).so.$(MAJ): $(SOBJS)
- $(CXX) -fPIC -nodefaultlibs $(CXXFLAGS) $(LDFLAGS) -shared -Wl,-soname,$@ -o $@ $^ $(LIBS)
-
-lib$(LIB).so: lib$(LIB).so.$(MAJ)
- ln -s $< $@
diff --git a/sys-libs/libcxxrt/files/Makefile.test b/sys-libs/libcxxrt/files/Makefile.test
deleted file mode 100644
index 55099426e7b4..000000000000
--- a/sys-libs/libcxxrt/files/Makefile.test
+++ /dev/null
@@ -1,7 +0,0 @@
-OBJS=test.o test_exception.o test_guard.o test_typeinfo.o
-
-cxxrttest: $(OBJS)
- $(CXX) -nodefaultlibs $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
-
-check: cxxrttest
- ./cxxrttest
diff --git a/sys-libs/libcxxrt/files/prepare_snapshot.sh b/sys-libs/libcxxrt/files/prepare_snapshot.sh
deleted file mode 100755
index 052076bc3813..000000000000
--- a/sys-libs/libcxxrt/files/prepare_snapshot.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-VERSION=$(date +%Y%m%d)
-BASE_VERSION="0.0"
-PACKAGE="libcxxrt-${BASE_VERSION}_p${VERSION}"
-
-git clone https://github.com/pathscale/libcxxrt.git ${PACKAGE}
-
-find "${PACKAGE}" -type d -name '.svn' -prune -print0 | xargs -0 rm -rf
-find "${PACKAGE}" -type d -name '.git' -prune -print0 | xargs -0 rm -rf
-
-tar cJf ${PACKAGE}.tar.xz ${PACKAGE}
-rm -rf ${PACKAGE}/
-
-echo "Tarball: \"${PACKAGE}.tar.xz\""
-
-echo "** all done **"
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild
deleted file mode 100644
index 5f6ec8f7caaa..000000000000
--- a/sys-libs/libcxxrt/libcxxrt-0.0_p20180311.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/pathscale/libcxxrt.git"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="git-2" || SCM=""
-
-inherit flag-o-matic toolchain-funcs portability ${SCM} multilib-minimal
-
-DESCRIPTION="C++ Runtime from PathScale, FreeBSD and NetBSD"
-HOMEPAGE="https://github.com/pathscale/libcxxrt"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- DEPEND="app-arch/xz-utils"
-else
- SRC_URI=""
-fi
-
-LICENSE="BSD-2"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-else
- KEYWORDS="amd64 arm arm64 x86"
-fi
-IUSE="+libunwind +static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="libunwind? ( || ( >=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
- sys-libs/llvm-libunwind[static-libs?,${MULTILIB_USEDEP}] ) )"
-DEPEND="${RDEPEND}
- ${DEPEND}"
-
-DOCS=( AUTHORS COPYRIGHT README )
-
-gcc_check() {
- if tc-is-gcc && [[ $(gcc-major-version) -lt 6 ]] && use test; then
- eerror "At least gcc-6 is required to run tests. Please switch to a newer"
- eerror "compiler before proceeding."
- die "gcc-6 required for tests"
- fi
-}
-
-pkg_pretend() {
- gcc_check
-}
-
-pkg_setup() {
- gcc_check
-}
-
-src_prepare() {
- cp "${FILESDIR}/Makefile" src/ || die
- cp "${FILESDIR}/Makefile.test" test/Makefile || die
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- # Notes: we build -nodefaultlibs to avoid linking to gcc libs.
- # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the libc.
- tc-export CC CXX AR
- append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
- cd "${BUILD_DIR}/src"
- LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
- use static-libs && emake static
-}
-
-multilib_src_test() {
- cd "${BUILD_DIR}/test"
- LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
- LIBS="-L${BUILD_DIR}/src -lcxxrt -l$(usex libunwind unwind gcc_s) -lc" \
- emake check
-}
-
-multilib_src_install() {
- # TODO: See README. Maybe hide it in a subdir and let only libcxx know about
- # it. FreeBSD head installs it in /lib
- dolib.so src/${PN}.so*
- use static-libs && dolib.a src/${PN}.a
-}
-
-multilib_src_install_all() {
- einstalldocs
- insinto /usr/include/libcxxrt/
- doins src/cxxabi.h src/unwind*.h
-}
diff --git a/sys-libs/libcxxrt/libcxxrt-9999.ebuild b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
deleted file mode 100644
index 2fdf7d613327..000000000000
--- a/sys-libs/libcxxrt/libcxxrt-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/pathscale/libcxxrt.git"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="git-r3" || SCM=""
-
-inherit flag-o-matic toolchain-funcs portability ${SCM} multilib-minimal
-
-DESCRIPTION="C++ Runtime from PathScale, FreeBSD and NetBSD"
-HOMEPAGE="https://github.com/pathscale/libcxxrt"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- DEPEND="app-arch/xz-utils"
-else
- SRC_URI=""
-fi
-
-LICENSE="BSD-2"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-else
- KEYWORDS=""
-fi
-IUSE="+libunwind +static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="libunwind? ( || ( >=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
- sys-libs/llvm-libunwind[static-libs?,${MULTILIB_USEDEP}] ) )"
-DEPEND="${RDEPEND}
- ${DEPEND}"
-
-DOCS=( AUTHORS COPYRIGHT README )
-
-gcc_check() {
- if tc-is-gcc && [[ $(gcc-major-version) -lt 6 ]] && use test; then
- eerror "At least gcc-6 is required to run tests. Please switch to a newer"
- eerror "compiler before proceeding."
- die "gcc-6 required for tests"
- fi
-}
-
-pkg_pretend() {
- gcc_check
-}
-
-pkg_setup() {
- gcc_check
-}
-
-src_prepare() {
- cp "${FILESDIR}/Makefile" src/ || die
- cp "${FILESDIR}/Makefile.test" test/Makefile || die
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- # Notes: we build -nodefaultlibs to avoid linking to gcc libs.
- # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the libc.
- tc-export CC CXX AR
- append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
- cd "${BUILD_DIR}/src"
- LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
- use static-libs && emake static
-}
-
-multilib_src_test() {
- cd "${BUILD_DIR}/test"
- LD_LIBRARY_PATH="${BUILD_DIR}/src:${LD_LIBRARY_PATH}" \
- LIBS="-L${BUILD_DIR}/src -lcxxrt -l$(usex libunwind unwind gcc_s) -lc" \
- emake check
-}
-
-multilib_src_install() {
- # TODO: See README. Maybe hide it in a subdir and let only libcxx know about
- # it. FreeBSD head installs it in /lib
- dolib.so src/${PN}.so*
- use static-libs && dolib.a src/${PN}.a
-}
-
-multilib_src_install_all() {
- einstalldocs
- insinto /usr/include/libcxxrt/
- doins src/cxxabi.h src/unwind*.h
-}
diff --git a/sys-libs/libcxxrt/metadata.xml b/sys-libs/libcxxrt/metadata.xml
deleted file mode 100644
index cb5673e8a934..000000000000
--- a/sys-libs/libcxxrt/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>aballier@gentoo.org</email>
- <name>Alexis Ballier</name>
- </maintainer>
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <use>
- <flag name="libunwind">Use libunwind instead of libgcc_s for unwinding. This should allow avoiding relying on <pkg>sys-devel/gcc</pkg> but for now clang is setup to use libgcc_s.</flag>
- </use>
- <upstream>
- <remote-id type="github">pathscale/libcxxrt</remote-id>
- </upstream>
-</pkgmetadata>