summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-14 22:58:33 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-14 23:22:20 +0100
commit83c0693aac6cfde5fd6ee2a1c19c0fa09b658ea9 (patch)
tree072232f9bbccaf8a7406b46ee055d8af623296ad /sys-libs
parentdev-libs/libgdata: bump to 0.17.7 for many upstream bug fixes (diff)
downloadgentoo-83c0693aac6cfde5fd6ee2a1c19c0fa09b658ea9.tar.gz
gentoo-83c0693aac6cfde5fd6ee2a1c19c0fa09b658ea9.tar.bz2
gentoo-83c0693aac6cfde5fd6ee2a1c19c0fa09b658ea9.zip
sys-libs/compiler-rt: Use llvm.eclass for reliable upgrade from :0
Use llvm.eclass to guarantee that the newly-installed LLVM slot will take precedence in PATH even if the package manager has not unmerged slot :0 yet.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild7
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild
index a921ea8b65e9..f448e2740c75 100644
--- a/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-4.0.0.ebuild
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
# TODO: fix unnecessary dep on Python upstream
-inherit cmake-utils flag-o-matic python-any-r1 toolchain-funcs
+inherit cmake-utils flag-o-matic llvm python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="http://llvm.org/"
@@ -34,6 +34,11 @@ S=${WORKDIR}/${P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 1bdd2efc42e5..7431230cf575 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
# TODO: fix unnecessary dep on Python upstream
-inherit cmake-utils flag-o-matic git-r3 python-any-r1 toolchain-funcs
+inherit cmake-utils flag-o-matic git-r3 llvm python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="http://llvm.org/"
@@ -34,6 +34,11 @@ DEPEND="
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null