summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-28 12:15:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-28 12:50:54 +0100
commit930795968e946440b812bca31d11fa82518bf8c3 (patch)
tree0a281fe0702231526c6a96e5652fc5e2cb8e3e3c /sys-libs
parentsys-libs/tdb: Removed old. (diff)
downloadgentoo-930795968e946440b812bca31d11fa82518bf8c3.tar.gz
gentoo-930795968e946440b812bca31d11fa82518bf8c3.tar.bz2
gentoo-930795968e946440b812bca31d11fa82518bf8c3.zip
sys-libs/talloc: Bump to version 2.1.16
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/Manifest1
-rw-r--r--sys-libs/talloc/talloc-2.1.16.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/sys-libs/talloc/Manifest b/sys-libs/talloc/Manifest
index 2864b89b6986..835cd3b7f4ed 100644
--- a/sys-libs/talloc/Manifest
+++ b/sys-libs/talloc/Manifest
@@ -1,5 +1,6 @@
DIST talloc-2.1.13.tar.gz 444608 BLAKE2B ac905d984e9ec438e8d7af473b37d7ccf8e4cf98d96b5a3b621f6c8203e7f5cd4d656602ac1fdfd22e0cab5853a8b54398c0c2ab4202517c4de73c5c90106d63 SHA512 003588fbcde340096b069ed4de0dc6c3e6a489b72abec83e9d3dedf40571a1bf07232d410cc86d8ca505ee49f7483a0043360e913de69106493346fae16a0e2b
DIST talloc-2.1.14.tar.gz 444589 BLAKE2B 3e47126eb41dc08befd22d7d41443dc5502d0bed239fa0fd32d63fe5374b4422165a7b364a8ad4a9f6e2d73b2db1dd4bada6aec3271c7b264f148d32974adcff SHA512 1fcc70bf283a4d9fb61faf1c57f80a9c158efbe996452740db9755e879ad72ee7bff6f6c9bed358e085c5c7f97c78800bb903161143af2202952b702141cc130
DIST talloc-2.1.15.tar.gz 634092 BLAKE2B e7dfad56e0f6325f50a025e4c92bb1d3d2b1d93897ebef59103c3ca40065c2724a47bb2d1104238b368870d2a944aacabb5f686f20e55134fa83dd68b2e27f6f SHA512 41896f8877e9a52e70b9881c41667dc52d7c1b03c3b248020fd909b794a4c5a4addee3eb944aa80ecfa3b03e6e5e1f67a62b5f3a5dcdc412b3e975352057ff40
+DIST talloc-2.1.16.tar.gz 634906 BLAKE2B 5f9f2e5ad53944d9a7b5bdb990aa6ab65a3f0d90cd9e368c16b11192e90fdecc873d59618dbf3e15896ecf7bbbbb2deaac91df6e231ad6b22b8e7c14bd382956 SHA512 a1affe4ad2a4cf19d4494017e0e6e37cdf9f8e6a98839c9e4e5c02758a7da7ea0040518de9b26707a60eb0a0eab29f939c6823e5840096dc124d351993e05c74
DIST talloc-2.1.5.tar.gz 436193 BLAKE2B 88a9ca32b6c6ae869e1761cb027847797e4ef3bb58dc618bae4b00f95637a0a8511f8704fa03ca1ca935127413a10d5297ba3843f0ea6992a97ce586f66cb705 SHA512 b938d67fcf4c6618f1149b4ec665957a604e3b07ee26e96ed36d94312db8f56b50498f69f9a07782f7f10a25047604e32b0d1786e1051d5f36b696c2755f8741
DIST talloc-2.1.9.tar.gz 440335 BLAKE2B dde37d99b3cfb63209cdb832444f0416b7c05151cec537e220e13b1148d59b89fb712b4211e078b23f1c6608c8be6df6055d5f394b091ccdea3966c04cbb73be SHA512 a8f051bb15aba769ca286acad0946605d0053b0d149b4da2e6ecc333345f3e603d13a7f062452ae0f165615a4170ebdd7f41fc1b46c7a360000d5308bc304cbb
diff --git a/sys-libs/talloc/talloc-2.1.16.ebuild b/sys-libs/talloc/talloc-2.1.16.ebuild
new file mode 100644
index 000000000000..65a8c5b61c9e
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.1.16.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils python-single-r1 multilib multilib-minimal
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="https://talloc.samba.org/"
+SRC_URI="https://www.samba.org/ftp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3+ LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris"
+IUSE="compat +python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ !!<sys-libs/talloc-2.0.5"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-libs/libxslt
+ ${PYTHON_DEPS}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+MULTILIB_WRAPPED_HEADERS=(
+ # python goes only for native
+ /usr/include/pytalloc.h
+)
+
+pkg_setup() {
+ # try to turn off distcc and ccache for people that have a problem with it
+ export DISTCC_DISABLE=1
+ export CCACHE_DISABLE=1
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # what would you expect of waf? i won't even waste time trying.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=(
+ $(usex compat --enable-talloc-compat1 '')
+ $(multilib_native_usex python '' --disable-python)
+ $([[ ${CHOST} == *-solaris* ]] && echo '--disable-symbol-versions')
+ )
+ waf-utils_src_configure "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ # waf is stupid, and no, we can't fix the build-system, since it's provided
+ # as a brilliant binary blob thats decompressed on the fly
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libtalloc.2.0.5.dylib || die
+ if use python ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libpytalloc-util.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${D}"$(python_get_sitedir)/talloc.bundle || die
+ fi
+ fi
+}