summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-23 15:12:39 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-23 15:14:07 -0400
commitedae0804767dbb7a2d5f71e847de473a9cff8638 (patch)
tree9b08bb6bbf6151edf052ed1f1c550e2a9b9ce51f /sys-libs
parentsourceware: convert to https:// URIs (diff)
downloadgentoo-edae0804767dbb7a2d5f71e847de473a9cff8638.tar.gz
gentoo-edae0804767dbb7a2d5f71e847de473a9cff8638.tar.bz2
gentoo-edae0804767dbb7a2d5f71e847de473a9cff8638.zip
sys-libs/newlib: build with --disable-newlib-supplied-syscalls
Switch myconf to an array at the same time to clean things up a bit.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/newlib-2.4.0.ebuild13
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild13
2 files changed, 18 insertions, 8 deletions
diff --git a/sys-libs/newlib/newlib-2.4.0.ebuild b/sys-libs/newlib/newlib-2.4.0.ebuild
index 12999bcabf4e..428276464d38 100644
--- a/sys-libs/newlib/newlib-2.4.0.ebuild
+++ b/sys-libs/newlib/newlib-2.4.0.ebuild
@@ -53,10 +53,15 @@ src_configure() {
unset LDFLAGS
CHOST=${CTARGET} strip-unsupported-flags
- local myconf=""
+ local myconf=(
+ # Disable legacy syscall stub code in newlib. These have been
+ # moved to libgloss for a long time now, so the code in newlib
+ # itself just gets in the way.
+ --disable-newlib-supplied-syscalls
+ )
[[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
+ && myconf+=( --disable-newlib-multithread ) \
+ || myconf+=( $(use_enable threads newlib-multithread) )
mkdir -p "${NEWLIBBUILD}"
cd "${NEWLIBBUILD}"
@@ -65,7 +70,7 @@ src_configure() {
econf \
$(use_enable unicode newlib-mb) \
$(use_enable nls) \
- ${myconf}
+ "${myconf[@]}"
}
src_compile() {
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index 69e50b0a9234..9ef5293db416 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -53,10 +53,15 @@ src_configure() {
unset LDFLAGS
CHOST=${CTARGET} strip-unsupported-flags
- local myconf=""
+ local myconf=(
+ # Disable legacy syscall stub code in newlib. These have been
+ # moved to libgloss for a long time now, so the code in newlib
+ # itself just gets in the way.
+ --disable-newlib-supplied-syscalls
+ )
[[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
+ && myconf+=( --disable-newlib-multithread ) \
+ || myconf+=( $(use_enable threads newlib-multithread) )
mkdir -p "${NEWLIBBUILD}"
cd "${NEWLIBBUILD}"
@@ -65,7 +70,7 @@ src_configure() {
econf \
$(use_enable unicode newlib-mb) \
$(use_enable nls) \
- ${myconf}
+ "${myconf[@]}"
}
src_compile() {